Untrusted input in Microsoft PowerShell allows remote code execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Microsoft PowerShell 7.4 from 7.4.0 before 7.4.21, PowerShell 7.5 from 7.5.0 before 7.5.12, and PowerShell 7.6 from 7.6.0 before 7.6.8 are affected. The flaw (CWE-807) is that PowerShell relies on untrusted inputs in a security decision. An unauthorized attacker can execute code over a network, but the attack requires user interaction.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Reliance on untrusted inputs in a security decision in Microsoft PowerShell allows an unauthorized attacker to execute code over a network.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Microsoft | PowerShell 7.4 | 7.4.0 to before 7.4.21 | 7.4.21 | Patch available | CNA |
| Microsoft | PowerShell 7.5 | 7.5.0 to before 7.5.12 | 7.5.12 | Patch available | CNA |
| Microsoft | PowerShell 7.6 | 7.6.0 to before 7.6.8 | 7.6.8 | Patch available | CNA |
- PowerShell 7.4 VendorMicrosoft Affected 7.4.0 to before 7.4.21 Fixed in 7.4.21 Patch available CNA
- PowerShell 7.5 VendorMicrosoft Affected 7.5.0 to before 7.5.12 Fixed in 7.5.12 Patch available CNA
- PowerShell 7.6 VendorMicrosoft Affected 7.6.0 to before 7.6.8 Fixed in 7.6.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:* | 7.4 to before 7.4.21; 7.5 to before 7.5.12; 7.6 to before 7.6.7 | Vulnerable | Microsoft |
- cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:* Versions 7.4 to before 7.4.21; 7.5 to before 7.5.12; 7.6 to before 7.6.7 Vulnerable ·Microsoft
Remediation
Update PowerShell 7.4 to version 7.4.21, PowerShell 7.5 to version 7.5.12, and PowerShell 7.6 to version 7.6.8.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA PowerShell 7.4 (Microsoft) Fixed in 7.4.21
- Fix · CNA PowerShell 7.5 (Microsoft) Fixed in 7.5.12
- Fix · CNA PowerShell 7.6 (Microsoft) Fixed in 7.6.8
Timeline
- 2026-10-13 Threatist record created from CVE-2026-96251
- 2026-10-13 Alias added: GHSA-xqvx-cfr9-2h2j
- 2026-10-14 Priority changed: LOW → MEDIUM
- 2026-10-23 Fix available: Microsoft/PowerShell [email protected] · CNA
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Microsoft Powershell vulnerabilities
- TI-2024-14152 .NET and Visual Studio Denial of Service Vulnerability CVSS 3.1HIGH 7.5
- TI-2022-19606 PowerShell Remote Code Execution Vulnerability CVSS 3.1HIGH 8.5
- TI-2018-06024 A remote code execution vulnerability exists in PowerShell Editor Services, aka… CVSS 3.1CRITICAL 9.8
- TI-2024-00056 NET, .NET Framework, and Visual Studio Security Feature Bypass Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-07392 .NET and Visual Studio Denial of Service Vulnerability CVSS 3.1HIGH 7.5
- TI-2024-17279 Microsoft QUIC Denial of Service Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2026-96251 · CVE Program
- CVE-2026-96251 · NVD
- FIRST EPSS
- GHSA-xqvx-cfr9-2h2j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences