Security feature bypass in Microsoft PowerShell
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Microsoft PowerShell 7.4 from 7.4.0 before 7.4.21, 7.5 from 7.5.0 before 7.5.12, and 7.6 from 7.6.0 before 7.6.8 contain an improperly implemented security check (CWE-358). An unauthenticated remote attacker can bypass a security feature if a user takes an action.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Improperly implemented security check for standard in Microsoft PowerShell allows an unauthorized attacker to bypass a security feature over a network.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Microsoft | PowerShell 7.4 | 7.4.0 to before 7.4.21 | 7.4.21 | Patch available | CNA |
| Microsoft | PowerShell 7.5 | 7.5.0 to before 7.5.12 | 7.5.12 | Patch available | CNA |
| Microsoft | PowerShell 7.6 | 7.6.0 to before 7.6.8 | 7.6.8 | Patch available | CNA |
- PowerShell 7.4 VendorMicrosoft Affected 7.4.0 to before 7.4.21 Fixed in 7.4.21 Patch available CNA
- PowerShell 7.5 VendorMicrosoft Affected 7.5.0 to before 7.5.12 Fixed in 7.5.12 Patch available CNA
- PowerShell 7.6 VendorMicrosoft Affected 7.6.0 to before 7.6.8 Fixed in 7.6.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:* | 7.4 to before 7.4.21; 7.5 to before 7.5.12; 7.6 to before 7.6.7 | Vulnerable | Microsoft |
- cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:* Versions 7.4 to before 7.4.21; 7.5 to before 7.5.12; 7.6 to before 7.6.7 Vulnerable ·Microsoft
Remediation
Update PowerShell 7.4 to 7.4.21, PowerShell 7.5 to 7.5.12, and PowerShell 7.6 to 7.6.8.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA PowerShell 7.4 (Microsoft) Fixed in 7.4.21
- Fix · CNA PowerShell 7.5 (Microsoft) Fixed in 7.5.12
- Fix · CNA PowerShell 7.6 (Microsoft) Fixed in 7.6.8
Timeline
- 2026-10-13 Threatist record created from CVE-2026-96303
- 2026-10-13 Alias added: GHSA-p862-mv9f-9294
- 2026-10-14 CISA SSVC decision points changed
- 2026-10-14 Priority changed: MEDIUM → LOW
- 2026-10-23 Fix available: Microsoft/PowerShell [email protected] · CNA
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Microsoft Powershell vulnerabilities
- TI-2024-14152 .NET and Visual Studio Denial of Service Vulnerability CVSS 3.1HIGH 7.5
- TI-2022-19606 PowerShell Remote Code Execution Vulnerability CVSS 3.1HIGH 8.5
- TI-2018-06024 A remote code execution vulnerability exists in PowerShell Editor Services, aka… CVSS 3.1CRITICAL 9.8
- TI-2024-00056 NET, .NET Framework, and Visual Studio Security Feature Bypass Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-07392 .NET and Visual Studio Denial of Service Vulnerability CVSS 3.1HIGH 7.5
- TI-2024-17279 Microsoft QUIC Denial of Service Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2026-96303 · CVE Program
- CVE-2026-96303 · NVD
- FIRST EPSS
- GHSA-p862-mv9f-9294 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences