Price validation flaw in SellKit lets attackers set order prices
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
The SellKit WordPress plugin, from 2.3.5 before 2.8.0, does not validate a client-supplied product price when totals are recalculated during checkout. An unauthenticated remote attacker can place orders for any purchasable product at a price of their choosing, with a low integrity impact. The flaw is linked to CWE-862. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The SellKit WordPress plugin before 2.8.0 does not validate a client-supplied product price when totals are recalculated during checkout, allowing unauthenticated attackers to place orders for any purchasable product at a price of their own choosing.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | SellKit | 2.3.5 to before 2.8.0 | 2.8.0 | Patch available | CNA |
- SellKit VendorUnknown Affected 2.3.5 to before 2.8.0 Fixed in 2.8.0 Patch available CNA
Remediation
Update SellKit to version 2.8.0, the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA SellKit (Unknown) Fixed in 2.8.0
Timeline
- 2026-10-14 Threatist record created from CVE-2026-94254
- 2026-10-14 Alias added: GHSA-gx6q-vm8j-vqvw
- 2026-10-16 CVSS score added · CISA ADP
- 2026-10-16 Weakness changed · CISA ADP
- 2026-10-16 CISA SSVC decision points changed
References
Sources
- CVE-2026-94254 · CVE Program
- CVE-2026-94254 · NVD
- FIRST EPSS
- GHSA-gx6q-vm8j-vqvw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences