Erlang OTP ssl client crash from malicious NewSessionTicket early_data
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 fixed, 3 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.
Summary
Erlang OTP ssl from OTP 23.3 before OTP 27.3.4.19, OTP 28.5.0.8, and OTP 29.1.2 is affected. The TLS 1.3 client decodes NewSessionTicket extensions as if they came from EncryptedExtensions, so it accepts a zero length early_data extension (CWE-1288). A malicious TLS 1.3 server can crash the client's node wide ticket store on the next automatic resumption, and repeated crashes can take down ssl for all connections on that node.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Description from the CNA
Improper Validation of Consistency within Input vulnerability in Erlang OTP ssl (tls_handshake_1_3, ssl_handshake and tls_client_ticket_store modules) allows a malicious TLS 1.3 server to cause a denial of service of the ssl application on the client node. The TLS 1.3 client decodes the extensions of a NewSessionTicket message as if they came from EncryptedExtensions. It therefore accepts a 0-length early_data extension, a form that is only valid in ClientHello and EncryptedExtensions. With {session_tickets, auto}, the client stores the ticket in the node-global tls_client_ticket_store. On the next automatic resumption, tls_handshake_1_3:get_max_early_data/1 crashes the store with a case_clause. Repeated crashes can exceed the restart intensity of the ssl supervisors, which use the rest_for_one strategy, and take down ssl for all connections on the node. This issue affects OTP from OTP 23.3 before OTP 27.3.4.19, OTP 28.5.0.8, and OTP 29.1.2, corresponding to ssl from 10.3 before 11.2.12.14, 11.6.0.7, and 11.7.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Erlang OTP to 27.3.4.19, 28.5.0.8, or 29.1.2, which contain ssl 11.2.12.14, 11.6.0.7, and 11.7.8 respectively. Red Hat fixes Red Hat Hardened Images in RHSA-2026:83217. Red Hat lists Red Hat OpenStack Platform 16.2, 17.1, and 18.0 as affected with no fix available.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Red Hat 1 advisory
- RHSA-2026:83217 Released 2026-10-14 · Red Hat rating ModerateRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images erlang27-27.3.4.19-0.1.hum1@aarch64, erlang27-27.3.4.19-0.1.hum1@s390x, erlang27-27.3.4.19-0.1.hum1@src +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 16.2 | Affected | No fix yet |
| Red Hat OpenStack Platform 17.1 | Affected | No fix yet |
| Red Hat OpenStack Platform 18.0 | Affected | No fix yet |
| Red Hat Hardened Images | Fixed | RHSA-2026:83217 |
Not affected: 1 product
- Red Hat OpenStack Platform 13 (Queens)
Timeline
- 2026-10-15 Threatist record created from CVE-2026-94200
- 2026-10-16 Priority changed: MEDIUM → LOW
- 2026-10-18 CISA SSVC decision points changed
- 2026-10-20 Fix available: RHSA-2026:83217 · Red Hat
- 2026-10-20 Fix available: Red Hat Hardened Images · Red Hat
- 2026-10-20 CVSS score added · Red Hat
- 2026-10-30 Affected versions changed · Red Hat
References
More Erlang vulnerabilities
- TI-2025-23504 Erlang/OTP SSH Vulnerable to Pre-Authentication RCE KEVCVSS 3.1CRITICAL 10.0
- TI-2026-48954 httpd parks a request worker indefinitely on a malformed chunk size sent after the headers CVSS 4.0HIGH 8.7
- TI-2023-26623 The SSH transport protocol with certain OpenSSH extensions, found in OpenSSH before 9.6… CVSS 3.1MEDIUM 5.9
- TI-2026-71037 Path traversal in rebar3 via unvalidated dependency app names CVSS 4.0HIGH 7.5
- TI-2024-36042 ssl fails to validate incorrect extened key usage CVSS 3.1MEDIUM 5.5
- TI-2020-10791 Rebar3 versions 3.0.0-beta.3 to 3.13.2 are vulnerable to OS command injection via URL… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-94200 · CVE Program
- CVE-2026-94200 · NVD
- FIRST EPSS
- CVE-2026-94200 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences