Scope bypass in Eclipse Vert.x Web ChainAuthHandler skips scope checks
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 1 fixed, 9 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-863.
Summary
Eclipse Vert.x versions 4.0.0 through 4.5.34, 5.0.0 through 5.0.12, 5.1.0 through 5.1.9 and 5.2.0 are affected. ChainAuthHandler in Eclipse Vert.x Web skips the scope checks set with withScope() or withScopes() when an earlier handler has already authenticated the user. A user with a valid token but insufficient scopes can reach resources protected by those scope requirements, which is incorrect authorization (CWE-863).
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
In Eclipse Vert.x versions [4.0.0, 4.5.34] or [5.0.0,5.0.12] or [5.1.0,5.1.9] or [5.2.0, 5.2.0], a scope bypass vulnerability exists in Eclipse Vert.x Web's ChainAuthHandler when used with scope-requiring authentication handlers such as JWTAuthHandler or OAuth2AuthHandler. When a user is already authenticated on the routing context by a preceding handler in the request pipeline, ChainAuthHandler skips all scope validation configured via withScope() or withScopes(). This affects both any() and all() chain modes. The root cause is that postAuthentication() relies on internal state that is only set during the authenticate() phase, which is skipped entirely for pre-authenticated users. In any() mode, the absence of this state causes the method to fall through without delegating scope checks to any handler. In all() mode, scope checks are unconditionally skipped. This allows a user with a valid token but insufficient scopes to access resources protected by scope requirements, provided they were authenticated by an earlier handler in the pipeline. The most common trigger is overlapping authentication handlers on nested routes, where a parent route authenticates broadly and a child route uses a chain to enforce specific scopes. The impacted component Maven coordinate is io.vertx:vertx-web
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Eclipse Foundation | Eclipse Vert.x | 4.0.0 – 4.5.34; 5.0.0 – 5.0.12; 5.1.0 – 5.1.9; 5.2.0 | — | No fix listed | CNA |
- Eclipse Vert.x VendorEclipse Foundation Affected 4.0.0 – 4.5.34; 5.0.0 – 5.0.12; 5.1.0 – 5.1.9; 5.2.0 Fixed in — No fix listed CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:eclipse:vert.x:*:*:*:*:*:*:*:* | 4.5.0 to before 4.5.35; 5.0.0 to before 5.1.10 | Vulnerable | Eclipse Foundation |
| cpe:2.3:a:eclipse:vert.x:5.2.0:*:*:*:*:*:*:* | 5.2.0 | Vulnerable | Eclipse Foundation |
- cpe:2.3:a:eclipse:vert.x:*:*:*:*:*:*:*:* Versions 4.5.0 to before 4.5.35; 5.0.0 to before 5.1.10 Vulnerable ·Eclipse Foundation
- cpe:2.3:a:eclipse:vert.x:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·Eclipse Foundation
Remediation
The sources list no fixed version for Eclipse Vert.x. Red Hat fixes Red Hat Build of Apache Camel 3.33.4.SP3 in RHSA-2026:95622 and lists Red Hat Build of Keycloak, Red Hat build of Quarkus and seven other products as affected with no plan available.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Red Hat 1 advisory
- RHSA-2026:95622 Released 2026-11-05 · Red Hat rating ImportantRed Hat Build of Apache Camel 4.18 for Quarkus 3.33 update is now available (RHBQ 3.33.4.SP3)
- Red Hat Build of Apache Camel 3.33.4.SP3 com.google.guava.guava-33.7.2.jre-redhat-00002.jar, io.vertx.vertx-grpc-server-4.5.35.redhat-00001.jar, io.vertx.vertx-web-4.5.35.redhat-00001.jar +4
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Exploit Intelligence | Affected | No fix yet |
| OpenShift Serverless | Affected | No fix yet |
| Red Hat Build of Keycloak | Affected | No fix yet |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet |
| Red Hat OpenShift Dev Spaces | Affected | No fix yet |
| Red Hat build of Apache Camel 4 for Quarkus 3 | Affected | No fix yet |
| Red Hat build of Apache Camel for Spring Boot 4 | Affected | No fix yet |
| Red Hat build of Apicurio Registry 3 | Affected | No fix yet |
| Red Hat build of Quarkus | Affected | No fix yet |
| Red Hat Build of Apache Camel 3.33.4.SP3 | Fixed | RHSA-2026:95622 |
Not affected: 2 products
- Red Hat Build of Apache Camel 3.33.4.SP3
- Red Hat Fuse 7
Timeline
- 2026-10-15 Threatist record created from CVE-2026-102460
- 2026-10-16 Priority changed: MEDIUM → LOW
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-18 Affected versions changed · Red Hat
- 2026-10-18 CVSS score added · Red Hat
- 2026-10-19 Weakness changed · CISA ADP
- 2026-10-19 Alias added: GHSA-wrr9-rmv8-g28m
- 2026-10-20 Affected versions changed · Red Hat
- 2026-10-20 CVSS score added · NVD
- 2026-11-06 Fix available: Red Hat Build of Apache Camel 3.33.4.SP3 · Red Hat
- 2026-11-06 Fix available: RHSA-2026:95622 · Red Hat
References
More Eclipse Foundation Vert.x vulnerabilities
- TI-2026-06017 Improper certificate validation in Eclipse Vert.x CVSS 4.0MEDIUM 6.9
- TI-2025-10971 In Eclipse Vert.x versions [4.0.0, 4.5.21] and [5.0.0, 5.0.4], a StaticHandler… CVSS 4.0MEDIUM 6.3
- TI-2019-13165 Path traversal in Eclipse Vert.x CVSS 3.1CRITICAL 9.8
- TI-2018-09003 XML external entity injection in Eclipse Vert.x CVSS 3.0CRITICAL 9.8
- TI-2018-09001 Path traversal in Eclipse Vert.x CVSS 3.0CRITICAL 9.8
- TI-2025-10972 Cross-site scripting in Eclipse Foundation Vert.x CVSS 4.0LOW 2.3
Sources
- CVE-2026-102460 · CVE Program
- CVE-2026-102460 · NVD
- FIRST EPSS
- GHSA-wrr9-rmv8-g28m · GitHub Advisory Database · CC BY 4.0
- CVE-2026-102460 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences