Read the docs
TI-2026-74491 Aliases CVE-2026-110679

Out-of-bounds read in OpenSIPS rtpproxy answer handling

Priority LOW 36CWE-119Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

OpenSIPS from 3.6.0 before 3.6.9 and from 4.0.0 before 4.0.2 is affected. The rtpproxy_answer function of the rtpproxy component reads memory outside the bounds of a buffer (CWE-125). A remote attacker without privileges or user interaction can trigger the flaw, with a low impact on confidentiality, integrity and availability.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the CNA

A vulnerability was determined in OpenSIPS up to 3.6.8/4.0.1. The impacted element is the function rtpproxy_offer/rtpproxy_answer of the component rtpproxy. This manipulation causes out-of-bounds read. The attack may be initiated remotely. Upgrading to version 3.6.9 and 4.0.2 is sufficient to resolve this issue. It is advisable to upgrade the affected component.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00307 23rd percentileScored 2026-11-07
Fix Fixed OpenSIPS: 3.6.9, 4.0.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—OpenSIPS3.6.0; 3.6.1; 3.6.2; 3.6.3; 3.6.4; 3.6.5; 3.6.6; 3.6.7; 3.6.8; 4.0.0; 4.0.13.6.9, 4.0.2Patch availableCNA
  • OpenSIPS Vendor— Affected 3.6.0; 3.6.1; 3.6.2; 3.6.3; 3.6.4; 3.6.5; 3.6.6; 3.6.7; 3.6.8; 4.0.0; 4.0.1 Fixed in 3.6.9, 4.0.2 Patch available CNA

CPE names CNA · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*——OpenSIPS
  • cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:* Versions — — ·OpenSIPS

Remediation

Upgrade OpenSIPS to version 3.6.9 or 4.0.2, whichever matches the installed release.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · CNA OpenSIPS Fixed in 3.6.9, 4.0.2

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-15 Threatist record created from CVE-2026-110679
  2. 2026-10-15 CISA SSVC decision points changed
  3. 2026-10-15 Priority changed: MEDIUM → LOW
  4. 2026-10-16 Affected versions changed · Red Hat
  5. 2026-10-16 CVSS score added · Red Hat

References

Sources