Cross-site scripting in QNAP QuFTP Service log handling
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
QNAP QuFTP Service versions from 1.4.x before 1.4.6, from 1.5.x before 1.5.5, and from 1.6.x before 1.6.5 are affected. A cross-site scripting flaw (CWE-79) lets malicious code be injected through log entries. A remote attacker who already holds a user account can exploit it to inject malicious code.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
A cross-site scripting (XSS) vulnerability has been reported to affect QuFTP Service. If a remote attacker gains a user account, they can then exploit the vulnerability to inject malicious code. We have already fixed the vulnerability in the following version: QuFTP Service 1.4.6 and later QuFTP Service 1.5.5 and later QuFTP Service 1.6.5 and later
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QNAP | QuFTP Service | 1.4.x to before 1.4.6; 1.5.x to before 1.5.5; 1.6.x to before 1.6.5 | 1.4.6, 1.5.5, 1.6.5 | Patch available | CNA |
- QuFTP Service VendorQNAP Affected 1.4.x to before 1.4.6; 1.5.x to before 1.5.5; 1.6.x to before 1.6.5 Fixed in 1.4.6, 1.5.5, 1.6.5 Patch available CNA
Remediation
Update QuFTP Service to 1.4.6 or later in the 1.4 branch, 1.5.5 or later in the 1.5 branch, or 1.6.5 or later in the 1.6 branch.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA QuFTP Service (QNAP Systems Inc.) Fixed in 1.4.6, 1.5.5, 1.6.5
Timeline
- 2026-10-16 Threatist record created from CVE-2026-47790
References
More QNAP vulnerabilities
- TI-2022-10581 DeadBolt Ransomware KEVCVSS 3.1CRITICAL 10.0
- TI-2021-09791 Improper Authorization Vulnerability in HBS 3 (Hybrid Backup Sync) KEVCVSS 3.1CRITICAL 10.0
- TI-2020-02221 Command Injection Vulnerability in QTS and QuTS hero KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05103 Path traversal in QNAP NAS devices running Photo Station KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05102 Path traversal in QNAP NAS devices running Photo Station KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05101 Improper input validation in QNAP NAS devices KEVCVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences