SQL injection in Vitepos POS for WooCommerce via bt operator
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The Vitepos (Point of Sale (POS) for WooCommerce) plugin by appsbd for WordPress is affected in all versions up to and including 3.6.1. Insufficient escaping and missing query preparation in the bt (BETWEEN) operator branch let an authenticated attacker with vendor-level access or higher append SQL queries via the src_by[].val.start and src_by[].val.end parameters, which enables blind SQL injection that can extract sensitive database information. This is an incomplete fix for a previously patched SQL injection in version 3.6.0, which covered only the gt, lt, le and ge operators. The weakness is CWE-89.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Vitepos – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to blind SQL Injection via the 'src_by[].val.start / src_by[].val.end (operator 'bt')' parameter in all versions up to, and including, 3.6.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with vendor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is an incomplete fix for a previously patched SQL injection (version 3.6.0), which addressed only the gt/lt/le/ge operators while leaving the 'bt' (BETWEEN) operator branch unpatched.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for Vitepos (Point of Sale (POS) for WooCommerce).
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-16 Threatist record created from CVE-2026-109414
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-16 Priority changed: MEDIUM → LOW
- 2026-10-16 Alias added: GHSA-vx38-3rqc-7pgm
References
Other 7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bb6c82b0-d9c7-4777-829d-885f24da4f36?source=cve
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vendor/appsbd-wp/appsbd-lite/appsbd_lite/v6/core/class-basemodel.php#L2925
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/libs/class-api-base.php#L467
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-vendor-api.php#L74
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-outlet-api.php#L66
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-purchase-api.php#L71
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3732582%40vitepos-lite&new=3732582%40vitepos-lite
More appsbd vulnerabilities
- TI-2024-36330 WordPress Elite Notification plugin 1.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-23707 WordPress Vite Coupon plugin <= 1.0.9 - CSRF to Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.6
- TI-2025-16181 WordPress Vitepos plugin <= 3.1.4 - Broken Authentication vulnerability CVSS 3.1HIGH 8.8
- TI-2025-12027 Unrestricted file upload in appsbd Vitepos – Point of Sale for WooCommerce CVSS 3.1HIGH 8.8
- TI-2026-75235 Vitepos Unauthenticated SQL Injection via 'src_by' Parameter CVSS 3.1HIGH 7.5
- TI-2026-39644 WordPress Vitepos plugin <= 3.4.2 - Sensitive Data Exposure vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2026-109414 · CVE Program
- CVE-2026-109414 · NVD
- FIRST EPSS
- GHSA-vx38-3rqc-7pgm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences