Squeeze plugin missing authorization lets Subscribers alter attachments
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Squeeze WordPress plugin before 1.8.1 does not perform a capability check on one of its AJAX actions. An authenticated user with a Subscriber role or higher can revert any attachment to its backup copy and permanently delete that backup and the plugin's generated WebP derivatives, regardless of ownership. The flaw is classified as Missing Authorization (CWE-862). Public exploit code is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Squeeze WordPress plugin before 1.8.1 does not perform a capability check on one of its AJAX actions, allowing authenticated users with a role as low as Subscriber to revert any attachment to its backup copy and to permanently delete that backup and the plugin's generated WebP derivatives, regardless of ownership.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Squeeze | before 1.8.1 | 1.8.1 | Patch available | CNA |
- Squeeze VendorUnknown Affected before 1.8.1 Fixed in 1.8.1 Patch available CNA
Remediation
Update Squeeze to version 1.8.1 or later, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Squeeze (Unknown) Fixed in 1.8.1
Timeline
- 2026-10-16 Threatist record created from CVE-2026-110029
- 2026-10-16 Alias added: GHSA-486q-7jvh-4x7q
References
Sources
- CVE-2026-110029 · CVE Program
- CVE-2026-110029 · NVD
- FIRST EPSS
- GHSA-486q-7jvh-4x7q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences