Read the docs

Improper certificate validation in GlitterWare Passy TLS handler

Priority LOW 28CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Attack requirements
None
Impact type
Security bypass, Spoofing
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-287 and CWE-295.

Summary

GlitterWare Passy versions 1.10.0 and 1.10.1 contain improper certificate validation (CWE-295) in the MyHttpOverrides function in lib/main.dart of the TLS Handler component. A remote attacker without privileges or user interaction can affect data integrity, but the attack is highly complex and difficult to exploit.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the CNA

A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00293 22nd percentileScored 2026-11-07
Fix Fixed Passy (GlitterWare): 1.10.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
GlitterWarePassy1.10.0; 1.10.11.10.2Patch availableCNA
  • Passy VendorGlitterWare Affected 1.10.0; 1.10.1 Fixed in 1.10.2 Patch available CNA

CPE names CNA · 1

CPEVersionsRoleVendor
cpe:2.3:a:passy:passy:*:*:*:*:*:*:*:*——Passy
  • cpe:2.3:a:passy:passy:*:*:*:*:*:*:*:* Versions — — ·Passy

Remediation

Upgrade GlitterWare Passy to version 1.10.2, which fixes the issue through patch 3d48df7cce05e39fa4de1e42768492307f26882e.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · CNA Passy (GlitterWare) Fixed in 1.10.2

Timeline

  1. 2026-10-19 Threatist record created from CVE-2026-112105
  2. 2026-10-19 Alias added: GHSA-j5q5-6pvc-m68p
  3. 2026-10-20 CISA SSVC decision points changed
  4. 2026-10-20 Priority changed: MEDIUM → LOW

References

Sources