OS command injection in JumpServer Template Rendering component
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-77.
Summary
JumpServer 4.10.0 up to and including 4.10.19 is affected. The Template Rendering component does not neutralize the IP/HOST argument, which lets attackers inject OS commands (CWE-78). A remote attacker with low privileges and some user interaction can exploit this flaw. The exploit has been publicly disclosed.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
A security vulnerability has been detected in JumpServer up to 4.10.19. The affected element is an unknown function of the component Template Rendering. The manipulation of the argument IP/HOST leads to os command injection. Remote exploitation of the attack is possible. The exploit has been disclosed publicly and may be used. Upgrading to version 5.0.0 is sufficient to fix this issue. The identifier of the patch is fcf2904cdb884230e9676f50f37a44d09fa97040. The affected component should be upgraded. The vendor confirms: "This issue was identified quite some time ago, and we have already fixed it in the v5 branch. (...) The fix will also be included in an upcoming v4 release.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | JumpServer | 4.10.0; 4.10.1; 4.10.2; 4.10.3; 4.10.4; 4.10.5; 4.10.6; 4.10.7; 4.10.8; 4.10.9; 4.10.10; 4.10.11; 4.10.12; 4.10.13; 4.10.14; 4.10.15; 4.10.16; 4.10.17; 4.10.18; 4.10.19 | 5.0.0 | Patch available | CNA |
- JumpServer Vendor— Affected 4.10.0; 4.10.1; 4.10.2; 4.10.3; 4.10.4; 4.10.5; 4.10.6; 4.10.7; 4.10.8; 4.10.9; 4.10.10; 4.10.11; 4.10.12; 4.10.13; 4.10.14; 4.10.15; 4.10.16; 4.10.17; 4.10.18; 4.10.19 Fixed in 5.0.0 Patch available CNA
CPE names CNA · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jumpserver:jumpserver:*:*:*:*:*:*:*:* | — | — | jumpserver |
- cpe:2.3:a:jumpserver:jumpserver:*:*:*:*:*:*:*:* Versions — — ·jumpserver
Remediation
Upgrade JumpServer to version 5.0.0, which fixes the issue, or apply patch fcf2904cdb884230e9676f50f37a44d09fa97040. The vendor says the fix will also be included in an upcoming v4 release.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA JumpServer Fixed in 5.0.0
Timeline
- 2026-10-19 Threatist record created from CVE-2026-112159
- 2026-10-20 Alias added: GHSA-qgr4-hq28-743m
- 2026-10-20 CISA SSVC decision points changed
- 2026-10-20 Priority changed: LOW → MEDIUM
References
Patch 3
Sources
- CVE-2026-112159 · CVE Program
- CVE-2026-112159 · NVD
- FIRST EPSS
- GHSA-qgr4-hq28-743m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences