Read the docs

DOM-based XSS in Stormshield web administration portal

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Stormshield Network Security versions 5.0.0 through 5.0.9 and 5.1.0 through 5.1.3 are affected. A DOM-based cross-site scripting flaw (CWE-79) in the web administration panel lets an attacker run script in the browser of an authenticated administrator. The attacker must craft a URL with a malicious script in a specific parameter and lure the administrator into opening it. The CVSS vector rates this as network attack with user interaction required.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the CNA

It is possible to execute a DOM-based Cross-Site Scripting attack against Stormshield’s web administration panel. To exploit this vulnerability, an attacker would need to craft a URL containing a malicious script payload within a specific parameter and lure an authenticated administrator into visiting that link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00226 13th percentileScored 2026-11-07
Fix Fixed Stormshield Network Security (Stormshield): 5.0.10, 5.1.4 EA

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
StormshieldStormshield Network Security5.0.0 – 5.0.9; 5.1.0 – 5.1.35.0.10, 5.1.4 EAPatch availableCNA
  • Stormshield Network Security VendorStormshield Affected 5.0.0 – 5.0.9; 5.1.0 – 5.1.3 Fixed in 5.0.10, 5.1.4 EA Patch available CNA

Remediation

Upgrade Stormshield Network Security to version 5.0.10 or 5.1.4 EA, which fix the flaw.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · CNA Stormshield Network Security (Stormshield) Fixed in 5.0.10, 5.1.4 EA

Timeline

  1. 2026-10-20 Threatist record created from CVE-2026-113465
  2. 2026-10-20 Alias added: GHSA-hfqr-g88q-6m8g
  3. 2026-10-20 CISA SSVC decision points changed
  4. 2026-10-20 Priority changed: MEDIUM → LOW

References

  • TI-2022-17498 zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in… CVSS 3.1CRITICAL 9.8
  • TI-2023-00271 X.400 address type confusion in X.509 GeneralName CVSS 3.1HIGH 7.4
  • TI-2022-13924 The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does… CVSS 3.1MEDIUM 6.5
  • TI-2023-06741 Buffer overflow in Cisco Secure Web Appliance CVSS 3.1CRITICAL 9.8
  • TI-2022-13925 The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does… CVSS 3.1MEDIUM 6.5
  • TI-2022-04067 Double free after calling PEM_read_bio_ex CVSS 3.1HIGH 7.5
See all 68 →

Sources