Read the docs

Stored cross-site scripting in Stormshield SNS enrollment portal

Priority LOW 33CWE-79Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Stormshield Network Security versions from 4.3.0 through 4.3.44, from 4.8.0 through 4.8.19, from 5.0.0 through 5.0.9 and from 5.1.0 through 5.1.3 contain a stored cross-site scripting flaw in the SNS enrollment portal (CWE-79). Through the captive portal, an attacker can inject script when requesting user creation. The stored script runs only when an administrator validates the request.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the CNA

A Stored Cross-Site Scripting vulnerability exists in the SNS enrollment Portal. Through the captive portal an attacker can inject an XSS when requesting user creation. The stored XSS can only be triggered during validation by the administrator.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00214 11th percentileScored 2026-11-07
Fix Fixed Stormshield Network Security (Stormshield): 4.3.45 QS, 4.8.20 LTSB, 5.0.10 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
StormshieldStormshield Network Security4.3.0 – 4.3.44; 4.8.0 – 4.8.19; 5.0.0 – 5.0.9; 5.1.0 – 5.1.34.3.45 QS, 4.8.20 LTSB, 5.0.10, 5.1.4 EAPatch availableCNA
  • Stormshield Network Security VendorStormshield Affected 4.3.0 – 4.3.44; 4.8.0 – 4.8.19; 5.0.0 – 5.0.9; 5.1.0 – 5.1.3 Fixed in 4.3.45 QS, 4.8.20 LTSB, 5.0.10, 5.1.4 EA Patch available CNA

Remediation

Upgrade to 4.3.45 QS, 4.8.20 LTSB, 5.0.10 or 5.1.4 EA, which fix the flaw. The sources do not list a vendor advisory identifier for this fix.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · CNA Stormshield Network Security (Stormshield) Fixed in 4.3.45 QS, 4.8.20 LTSB, 5.0.10, 5.1.4 EA

Timeline

  1. 2026-10-20 Threatist record created from CVE-2026-113808
  2. 2026-10-21 Alias added: GHSA-wrgg-3rf4-mcjj

References

  • TI-2022-17498 zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in… CVSS 3.1CRITICAL 9.8
  • TI-2023-00271 X.400 address type confusion in X.509 GeneralName CVSS 3.1HIGH 7.4
  • TI-2022-13924 The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does… CVSS 3.1MEDIUM 6.5
  • TI-2023-06741 Buffer overflow in Cisco Secure Web Appliance CVSS 3.1CRITICAL 9.8
  • TI-2022-13925 The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does… CVSS 3.1MEDIUM 6.5
  • TI-2022-04067 Double free after calling PEM_read_bio_ex CVSS 3.1HIGH 7.5
See all 68 →

Sources