Stored XSS in Stormshield Network Security enrollment portal
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Stormshield Network Security versions 4.8.0 through 4.8.19, 5.0.0 through 5.0.9 and 5.1.0 through 5.1.3 contain a stored cross-site scripting flaw in the SNS enrollment portal (CWE-79). An attacker who can reach the captive portal can inject script while requesting certificate creation for a user. The script runs when an administrator validates the request, and the attack requires user interaction and local access.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
A Stored Cross-Site Scripting vulnerability exists in the SNS enrollment Portal. Through the captive portal an attacker can inject an XSS when requesting certificate creation for user. The stored XSS can only be triggered during validation by the administrator.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Stormshield | Stormshield Network Security | 4.8.0 – 4.8.19; 5.0.0 – 5.0.9; 5.1.0 – 5.1.3 | 4.8.20 LTSB, 5.0.10, 5.1.4 EA | Patch available | CNA |
- Stormshield Network Security VendorStormshield Affected 4.8.0 – 4.8.19; 5.0.0 – 5.0.9; 5.1.0 – 5.1.3 Fixed in 4.8.20 LTSB, 5.0.10, 5.1.4 EA Patch available CNA
Remediation
Update Stormshield Network Security to 4.8.20 LTSB, 5.0.10 or 5.1.4 EA.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Stormshield Network Security (Stormshield) Fixed in 4.8.20 LTSB, 5.0.10, 5.1.4 EA
Timeline
- 2026-10-20 Threatist record created from CVE-2026-113810
- 2026-10-21 Alias added: GHSA-5pf7-8c56-xhx6
References
More Stormshield vulnerabilities
- TI-2022-17498 zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in… CVSS 3.1CRITICAL 9.8
- TI-2023-00271 X.400 address type confusion in X.509 GeneralName CVSS 3.1HIGH 7.4
- TI-2022-13924 The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does… CVSS 3.1MEDIUM 6.5
- TI-2023-06741 Buffer overflow in Cisco Secure Web Appliance CVSS 3.1CRITICAL 9.8
- TI-2022-13925 The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does… CVSS 3.1MEDIUM 6.5
- TI-2022-04067 Double free after calling PEM_read_bio_ex CVSS 3.1HIGH 7.5
Sources
- CVE-2026-113810 · CVE Program
- CVE-2026-113810 · NVD
- FIRST EPSS
- GHSA-5pf7-8c56-xhx6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences