Missing authorization in Synchrony Financing lets attackers take over orders
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.
Summary
The Synchrony Financing WordPress plugin from 1.0.5 before 1.1.2 does not properly authorise requests to one of its REST routes that modifies WooCommerce orders (CWE-863). An unauthenticated attacker can reassign any order to an account they control, tamper with its details, and read the associated customer's personal data. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Synchrony Financing WordPress plugin before 1.1.2 does not properly authorise requests to one of its REST routes that modifies WooCommerce orders, allowing unauthenticated attackers to reassign any order to an account they control, tamper with its details, and read the associated customer's personal data.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Synchrony Financing | 1.0.5 to before 1.1.2 | 1.1.2 | Patch available | CNA |
- Synchrony Financing VendorUnknown Affected 1.0.5 to before 1.1.2 Fixed in 1.1.2 Patch available CNA
Remediation
Update Synchrony Financing to version 1.1.2 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Synchrony Financing (Unknown) Fixed in 1.1.2
Timeline
- 2026-10-21 Threatist record created from CVE-2026-100145
- 2026-10-21 Alias added: GHSA-mr5q-g9rw-x79g
References
Sources
- CVE-2026-100145 · CVE Program
- CVE-2026-100145 · NVD
- FIRST EPSS
- GHSA-mr5q-g9rw-x79g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences