Stored cross-site scripting in Falang multilanguage for WordPress
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Falang multilanguage for WordPress plugin before 1.4.6 does not perform a capability check when saving term translations (CWE-79). Any logged-in user with Subscriber access or above can store content that is output without proper escaping and runs in the browsers of higher-privileged users such as administrators. A public exploit link is listed in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Falang multilanguage for WordPress plugin before 1.4.6 does not perform a capability check when saving term translations, and exposes a valid nonce to any logged-in user through an unprotected handler, allowing users with Subscriber-level access and above to store content that is later output without proper escaping, leading to Stored Cross-Site Scripting that executes in the context of higher-privileged users such as administrators.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Falang multilanguage for WordPress | before 1.4.6 | 1.4.6 | Patch available | CNA |
- Falang multilanguage for WordPress VendorUnknown Affected before 1.4.6 Fixed in 1.4.6 Patch available CNA
Remediation
Update Falang multilanguage for WordPress to version 1.4.6, the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Falang multilanguage for WordPress (Unknown) Fixed in 1.4.6
Timeline
- 2026-10-21 Threatist record created from CVE-2026-105262
- 2026-10-21 Alias added: GHSA-r8cc-m979-hm23
References
Sources
- CVE-2026-105262 · CVE Program
- CVE-2026-105262 · NVD
- FIRST EPSS
- GHSA-r8cc-m979-hm23 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences