Privilege escalation in Simple Banner WordPress plugin via user permissions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.
Summary
The Simple Banner WordPress plugin before 3.3.3 does not correctly limit the capabilities it grants to user roles that an administrator allows to manage its banners. Those roles receive the full administrator capability (CWE-269). An authenticated user with a low-privileged role can escalate their privileges and fully compromise the site. An exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Simple Banner WordPress plugin before 3.3.3 does not correctly limit the capabilities it grants to the user roles an administrator allows to manage its banners, granting such roles the full administrator capability, which allows users in a low-privileged role to escalate their privileges and fully compromise the site.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Simple Banner | before 3.3.3 | 3.3.3 | Patch available | CNA |
- Simple Banner VendorUnknown Affected before 3.3.3 Fixed in 3.3.3 Patch available CNA
Remediation
Update Simple Banner to version 3.3.3, which fixes the issue.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Simple Banner (Unknown) Fixed in 3.3.3
Timeline
- 2026-10-21 Threatist record created from CVE-2026-107506
- 2026-10-21 Alias added: GHSA-j3vp-w9x8-7pp7
References
Sources
- CVE-2026-107506 · CVE Program
- CVE-2026-107506 · NVD
- FIRST EPSS
- GHSA-j3vp-w9x8-7pp7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences