Stored cross-site scripting in WP Job Openings plugin for WordPress
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The HireZoot WordPress plugin before 4.1.1 does not sanitise or escape some stored data before showing it in the admin dashboard (CWE-79). It also reverses the HTML-entity encoding that would otherwise neutralise that data. An attacker with the Author role can store script that runs in the browser of a logged-in administrator who views the dashboard. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The HireZoot WordPress plugin before 4.1.1 does not sanitise and escape some of its stored data before outputting it in the admin dashboard, and additionally reverses the HTML-entity encoding that would otherwise neutralise it, allowing users with the Author role to perform Stored Cross-Site Scripting attacks that execute in the context of a logged-in administrator.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | HireZoot | before 4.1.1 | 4.1.1 | Patch available | CNA |
- HireZoot VendorUnknown Affected before 4.1.1 Fixed in 4.1.1 Patch available CNA
Remediation
Update the HireZoot plugin to version 4.1.1, which is the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA HireZoot (Unknown) Fixed in 4.1.1
Timeline
- 2026-10-21 Threatist record created from CVE-2026-107790
- 2026-10-21 Alias added: GHSA-3fc4-j778-wv4x
References
Sources
- CVE-2026-107790 · CVE Program
- CVE-2026-107790 · NVD
- FIRST EPSS
- GHSA-3fc4-j778-wv4x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences