Integer overflow in Eclipse OpenJ9 JITServer enables remote DoS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
Eclipse OpenJ9 from 0.8.0 before 0.63 is affected. An integer overflow in MessageBuffer::computeRequiredCapacity() (CWE-190) occurs when the JITServer component reads the initial 4-byte length field of an incoming TCP connection, and it makes the compilation worker thread loop forever at nearly full CPU. An unauthenticated remote attacker can open a small number of crafted TCP connections to exhaust the worker thread pool, which silently halts compilation for all connected client JVMs.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
In Eclipse OpenJ9 versions prior to 0.63.0, the JITServer component is vulnerable to a pre-authentication remote denial of service. When processing the initial 4-byte length field of an incoming TCP connection, an integer overflow in `MessageBuffer::computeRequiredCapacity()` causes the receiving compilation worker thread to enter an infinite loop consuming ~100% CPU. An unauthenticated remote attacker can exploit this by opening a small number of crafted TCP connections to exhaust the entire worker thread pool, silently halting compilation services for all connected client JVMs.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Eclipse Foundation | Eclipse OpenJ9 | 0.8.0 to before 0.63 | 0.63 | Patch available | CNA |
- Eclipse OpenJ9 VendorEclipse Foundation Affected 0.8.0 to before 0.63 Fixed in 0.63 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:eclipse:openj9:*:*:*:*:*:*:*:* | — | — | Eclipse Foundation |
- cpe:2.3:a:eclipse:openj9:*:*:*:*:*:*:*:* Versions — — ·Eclipse Foundation
Remediation
Upgrade Eclipse OpenJ9 to version 0.63 or later, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Eclipse OpenJ9 (Eclipse Foundation) Fixed in 0.63
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Eclipse OpenJ9 0.63
3 records Highest priority Priority MEDIUM 3 MEDIUM
Other records, highest priority first
- TI-2026-78629 Integer underflow in Eclipse OpenJ9 JITServer crashes processPriority MEDIUM 44
- TI-2026-78626 Out-of-bounds heap reads in Eclipse OpenJ9 JITServer enable denial of servicePriority MEDIUM 44
Timeline
- 2026-10-21 Threatist record created from CVE-2026-111074
- 2026-10-21 Alias added: GHSA-rr74-gf97-xpw7
- 2026-10-22 Priority changed: MEDIUM → LOW
- 2026-10-26 CISA SSVC decision points changed
- 2026-10-26 Priority changed: LOW → MEDIUM
References
More Eclipse Foundation vulnerabilities
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2026-81947 Unauthenticated command injection in Eclipse Che che-machine-exec CVSS 3.1CRITICAL 9.8
- TI-2026-13216 CWE-863: ABAC authorization bypass via trailing slash route normalization in Eclipse BaSyx Go Components CVSS 3.1CRITICAL 9.8
- TI-2026-06514 Path traversal in Eclipse BaSyx CVSS 3.1CRITICAL 10.0
- TI-2026-01382 In the Eclipse Theia Website repository, the GitHub Actions workflow… CVSS 3.1CRITICAL 10.0
- TI-2026-74697 Authentication bypass in Eclipse Jetty EthereumAuthenticator CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-111074 · CVE Program
- CVE-2026-111074 · NVD
- FIRST EPSS
- GHSA-rr74-gf97-xpw7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences