Improper authentication in WholesaleX lets attackers bypass account approval
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-287.
Summary
The WholesaleX WordPress plugin before 3.0.9 does not check that a stored account confirmation code is set before comparing it with the one supplied in a request. This improper authentication flaw (CWE-287) lets an unauthenticated remote attacker activate pending accounts and bypass the administrator approval required before login. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The WholesaleX WordPress plugin before 3.0.9 does not check that a stored account confirmation code is set before comparing it with the one supplied in a request, allowing unauthenticated users to activate pending accounts and bypass the administrator approval required before login.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WholesaleX | before 3.0.9 | 3.0.9 | Patch available | CNA |
- WholesaleX VendorUnknown Affected before 3.0.9 Fixed in 3.0.9 Patch available CNA
Remediation
Update WholesaleX to version 3.0.9 or later, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA WholesaleX (Unknown) Fixed in 3.0.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WholesaleX 3.0.9
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-78637 Sensitive user import file exposed in WholesaleX WordPress pluginPriority LOW 26
Timeline
- 2026-10-21 Threatist record created from CVE-2026-111955
- 2026-10-21 Alias added: GHSA-xm5m-h552-37c3
References
Sources
- CVE-2026-111955 · CVE Program
- CVE-2026-111955 · NVD
- FIRST EPSS
- GHSA-xm5m-h552-37c3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences