Privilege escalation in HIPAA Forms WordPress plugin via role update
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.
Summary
The HIPAA Forms WordPress plugin before 3.3.2 is affected. A request that rebuilds its custom user role does not check capabilities (CWE-269). An attacker who already holds that role can grant it administrator-level capabilities and escalate their privileges. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The HIPAA Forms WordPress plugin before 3.3.2 does not perform a capability check when handling a request that rebuilds its own custom user role, allowing a user who already holds that role to grant it administrator-level capabilities and escalate their privileges.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | HIPAA Forms | before 3.3.2 | 3.3.2 | Patch available | CNA |
- HIPAA Forms VendorUnknown Affected before 3.3.2 Fixed in 3.3.2 Patch available CNA
Remediation
Upgrade the HIPAA Forms WordPress plugin to version 3.3.2.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA HIPAA Forms (Unknown) Fixed in 3.3.2
Timeline
- 2026-10-22 Threatist record created from CVE-2026-109927
- 2026-10-22 Alias added: GHSA-fqh5-mr22-f9g4
- 2026-10-22 CVSS score added · CISA ADP
- 2026-10-22 Weakness changed · CISA ADP
- 2026-10-22 CISA SSVC decision points changed
References
Sources
- CVE-2026-109927 · CVE Program
- CVE-2026-109927 · NVD
- FIRST EPSS
- GHSA-fqh5-mr22-f9g4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences