Read the docs
TI-2026-79310 Aliases GHSA-2464-fhr4-w9xw

Next.js image optimization memory flaw enables remote code execution

Priority LOW 38CWE-1395Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

The npm package next from 10.0.0 before 15.5.28 and from 16.0.0 before 16.4.1 is affected. A memory-related flaw in an upstream library used for Image Optimization can lead to remote code execution when Next.js runs on glibc-based Linux. The source cites CWE-1395, a dependency on a vulnerable third-party component.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the GitHub advisory

## Impact A memory-related vulnerability has been discovered in an upstream library used for Image Optimization can lead to possible remote code execution (RCE) when Next.js runs on glibc-based Linux. ## Workaround Ensure the version of `sharp` used by Next.js is greater than or equal to `0.35.5`. Fresh installs automatically get a fixed version of `sharp`. Upgrading Next.js to the patched versions will ensure package managers automatically provide a fixed version of `sharp` to Next.js.

Why it matters now

Fix Fixed next (npm): 15.5.28, 16.4.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—next (npm)10.0.0 to before 15.5.2815.5.28Patch availableGHSA-2464-fhr4-w9xw
—next (npm)16.0.0 to before 16.4.116.4.1Patch availableGHSA-2464-fhr4-w9xw
  • next (npm) Vendor— Affected 10.0.0 to before 15.5.28 Fixed in 15.5.28 Patch available GHSA-2464-fhr4-w9xw
  • next (npm) Vendor— Affected 16.0.0 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-2464-fhr4-w9xw

Remediation

Upgrade next to version 15.5.28 for the 15.x branch or 16.4.1 for the 16.x branch. Alternatively, ensure the version of sharp used by Next.js is 0.35.5 or greater.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · GHSA-2464-fhr4-w9xw next (npm) Fixed in 15.5.28 Advisory →
  • Fix · GHSA-2464-fhr4-w9xw next (npm) Fixed in 16.4.1 Advisory →

Timeline

  1. 2026-10-22 Threatist record created from GHSA-2464-fhr4-w9xw

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences