Unauthenticated remote code execution in Next.js use cache functions
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-502.
Summary
The next npm package from 16.0.0 before 16.4.1 is affected. Deserialization of untrusted data (CWE-502) in applications using the App router with Cache Component lets an unauthenticated remote attacker execute code. The flaw applies to applications that have a use cache function returning multiple typed arrays.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the GitHub advisory
## Impact A vulnerability in applications using App router with Cache Component can lead to remote code execution. The application needs to have a `use cache` function that returns multiple typed arrays. ## Workaround There is no known workaround for affected applications with such `use cache` functions. You should upgrade immediately even if your application does not have similar functions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | next (npm) | 16.0.0 to before 16.4.1 | 16.4.1 | Patch available | GHSA-673q-mjm6-r5xr |
- next (npm) Vendor— Affected 16.0.0 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-673q-mjm6-r5xr
Remediation
Upgrade the next npm package to 16.4.1, the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · GHSA-673q-mjm6-r5xr next (npm) Fixed in 16.4.1 Advisory →
Timeline
- 2026-10-22 Threatist record created from GHSA-673q-mjm6-r5xr
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences