Memory leak in MessagePack C extension when map key validation fails
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 14 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-401.
Summary
MessagePack for Python (msgpack) from 0 before 1.2.3 has a flaw in its C extension, where a decoded map value is leaked when deserialization rejects a key under strict_map_key=True, the default. An unauthenticated remote attacker can send repeated malformed input to applications that deserialize untrusted MessagePack data, causing unbounded memory growth and denial of service (CWE-401). Both unpackb() and the streaming Unpacker API are affected.
Written with Claude Haiku 5.5 from the sources below · 2026-11-02
Description from the CNA
MessagePack is the serializer implementation for Python msgpack.org. Prior to 1.2.3, the msgpack-python C extension (msgpack._cmsgpack) leaks a decoded map value when deserialization rejects a key with strict_map_key=True (the default). Repeated malformed inputs can cause unbounded process memory growth and denial of service in applications that deserialize attacker-controlled MessagePack data. Both unpackb() and the streaming Unpacker API are affected. The pure-Python fallback does not exhibit this leak in the reported tests. This issue is fixed in version 1.2.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| msgpack | msgpack-python | before 1.2.3 | 1.2.3 | Patch available | CNA |
| — | msgpack (PyPI) | before 1.2.3 | 1.2.3 | Patch available | GHSA-j586-36cw-2gc2 |
- msgpack-python Vendormsgpack Affected before 1.2.3 Fixed in 1.2.3 Patch available CNA
- msgpack (PyPI) Vendor— Affected before 1.2.3 Fixed in 1.2.3 Patch available GHSA-j586-36cw-2gc2
Remediation
Upgrade the msgpack package on PyPI to version 1.2.3. The sources list no fixed version for msgpack-python. Red Hat lists no available plan for Red Hat Enterprise Linux 10, Red Hat OpenShift Container Platform 4, Red Hat OpenShift AI (RHOAI), Red Hat Satellite 6, Red Hat Quay 3, and other products.
Written with Claude Haiku 5.5 from the sources below · 2026-11-02
- Fix · CNA msgpack-python (msgpack) Fixed in 1.2.3
- Fix · GHSA-j586-36cw-2gc2 msgpack (PyPI) Fixed in 1.2.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Lightspeed Services for Advanced Cluster Management | Affected | No fix yet |
| Pen Drive Powered by Red Hat Lightspeed | Affected | No fix yet |
| Red Hat AI Inference Server | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet |
| Red Hat Enterprise Linux 10 | Affected | No fix yet |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet |
| Red Hat Lightspeed Services for OCP | Affected | No fix yet |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
| Red Hat OpenStack Platform 16.2 | Affected | No fix yet |
| Red Hat OpenStack Platform 17.1 | Affected | No fix yet |
| Red Hat OpenStack Platform 18.0 | Affected | No fix yet |
| Red Hat Quay 3 | Affected | No fix yet |
| Red Hat Satellite 6 | Affected | No fix yet |
Not affected: 5 products
- Red Hat Ansible Automation Platform 2
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat OpenShift AI (RHOAI)
Timeline
- 2026-10-22 Threatist record created from CVE-2026-114613
- 2026-10-23 Affected versions changed · Red Hat
- 2026-10-23 CVSS score added · Red Hat
- 2026-10-23 Priority changed: MEDIUM → LOW
- 2026-10-24 CISA SSVC decision points changed
- 2026-10-24 Affected versions changed · Red Hat
- 2026-10-27 Alias added: GHSA-j586-36cw-2gc2
- 2026-10-31 Priority changed: LOW → MEDIUM
- 2026-11-02 Affected versions changed · Red Hat
References
More msgpack vulnerabilities
- TI-2026-17336 Uncontrolled resource consumption in msgpack-java CVSS 3.1HIGH 7.5
- TI-2026-61499 msgpack-java through 0.9.12 Stack Overflow via Nested Arrays CVSS 4.0MEDIUM 6.9
- TI-2026-51079 msgpack-c Integer Overflow in msgpack_unpacker_expand_buffer Causes a False-Success Undersized Reservation CVSS 4.0MEDIUM 5.8
- TI-2026-39368 MessagePack::Buffer#clear Use-After-Free that Enables Cross-Buffer Disclosure CVSS 4.0LOW 2.1
- TI-2026-41435 MessagePack: Out-of-bounds read/crash on Unpacker reuse after caught error CVSS 3.1HIGH 7.5
- TI-2026-61500 msgpack-java through 0.9.12 Integer Overflow via MAP32 CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-114613 · CVE Program
- CVE-2026-114613 · NVD
- FIRST EPSS
- GHSA-j586-36cw-2gc2 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-114613 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences