Author-level content injection in Essential Addons for Elementor
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-345.
Summary
The Essential Addons for Elementor WordPress plugin before 6.8.7 does not validate the HTML tag setting of some of its widgets before using it to build markup. A user with the author role or above can inject iframe and form elements into published pages. The flaw is tracked as CWE-345, and an exploit link is listed in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Essential Addons for Elementor WordPress plugin before 6.8.7 does not validate the HTML tag setting of some of its widgets before using it to build markup, which could allow users with the author role and above to inject iframe and form elements into published pages.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Essential Addons for Elementor | before 6.8.7 | 6.8.7 | Patch available | CNA |
- Essential Addons for Elementor VendorUnknown Affected before 6.8.7 Fixed in 6.8.7 Patch available CNA
Remediation
Update Essential Addons for Elementor to version 6.8.7, which is the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Essential Addons for Elementor (Unknown) Fixed in 6.8.7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Essential Addons for Elementor 6.8.7
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-79566 Incorrect authorization in Essential Addons for Elementor approvalPriority LOW 18
Timeline
- 2026-10-23 Threatist record created from CVE-2026-110510
- 2026-10-23 Alias added: GHSA-282g-jjg9-h9cq
- 2026-10-23 CVSS score added · CISA ADP
- 2026-10-23 Weakness changed · CISA ADP
- 2026-10-23 CISA SSVC decision points changed
References
Sources
- CVE-2026-110510 · CVE Program
- CVE-2026-110510 · NVD
- FIRST EPSS
- GHSA-282g-jjg9-h9cq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences