Wrap-around bug in Linux kernel md/raid5 stripe batch comparison
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Partial Red Hat: 7 without a fix
No CVSS vector from any source. Fix status from CNA and Red Hat.
Summary
Linux kernel versions from 4.1 onward are affected in the md/raid5 driver, where stripe batch bm_seq values are compared as plain numbers. After the 32-bit sequence counter wraps, a newer value can compare as smaller than an older one, and the comparison now uses a wrap-safe calculation.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
In the Linux kernel, the following vulnerability has been resolved: md/raid5: let stripe batch bm_seq comparison wrap-safe Once the 32-bit seq wraps, a newer bm_seq can look smaller than old, so .. covert to wrap-safe calculate way.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
Update the Linux kernel to 5.10.271, 5.15.222, 6.1.189, 6.6.158, 6.12.111, 6.18.53 or 7.2, or to the mainline commit that fixes it. Red Hat Enterprise Linux 6 has no fix planned, and the sources list no fixed version for Red Hat Enterprise Linux 7, 8, 9, 10 or Red Hat OpenShift Container Platform 4 and 5.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Linux (Linux) Fixed in 5.10.271, 5.15.222, 6.1.189, 6.6.158, 6.12.111, 6.18.53, 7.2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 5 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-23 Threatist record created from CVE-2026-98902
- 2026-10-23 Alias added: GHSA-3qj5-vw52-69q7
- 2026-10-26 Fix available: Linux/Linux@0 · CNA
- 2026-10-26 Affected versions changed · Red Hat
- 2026-10-26 CVSS score added · Red Hat
- 2026-11-06 Affected versions changed · Red Hat
References
Other 7
- https://git.kernel.org/stable/c/647c7289a3960118e249c0a53da6f1ebba1e47a3
- https://git.kernel.org/stable/c/ffdd3aee932fc293456678f6b0200ffe9bf12a6d
- https://git.kernel.org/stable/c/628b14d0744bd5dfe176ea93559071cdcde14255
- https://git.kernel.org/stable/c/2fdc51228d9a8cad2d727d5aef732cc66fc6d56e
- https://git.kernel.org/stable/c/c5c89e1a872a84019f674f5107111e6e6b7cc30f
- https://git.kernel.org/stable/c/cc8eb1715673de850f14376782151f68f73ae3ce
- https://git.kernel.org/stable/c/00e93faf4cea9e8802ac5dfee0952d84fc95c40f
More Linux vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2021-02452 Incorrect authorization in Ubuntu linux kernel KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
Sources
- CVE-2026-98902 · CVE Program
- CVE-2026-98902 · NVD
- FIRST EPSS
- GHSA-3qj5-vw52-69q7 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-98902 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences