Linux kernel dm-crypt mishandles lmk IV mode with AEAD ciphers
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Partial Red Hat: 4 without a fix
No CVSS vector from any source. Fix status from CNA and Red Hat.
Summary
The Linux kernel from 4.12 has a flaw in dm-crypt. Loading a crypt table line that pairs an AEAD cipher such as gcm(aes) with the lmk IV mode causes an oops, because the kernel reads past the end of an array of transforms. Only root can trigger the memory corruption, so the source does not treat it as a security bug.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
In the Linux kernel, the following vulnerability has been resolved: dm-crypt: reject the lmk IV mode with AEAD ciphers A "capi:" table line that pairs an AEAD cipher with the lmk IV mode, for example "capi:gcm(aes)-lmk" with the integrity:28:aead option, causes an oops when it is loaded. lmk sets tfms_count to 64, but crypt_alloc_tfms_aead only allocates one transform, so crypt_setkey reads past the end of the tfms_aead array and calls crypto_aead_setkey on the values it finds there. lmk exists for compatibility with Loop-AES, which uses CBC, so refuse it with an AEAD cipher rather than allocate 64 AEAD transforms. The check cannot go in crypt_iv_lmk_ctr with the other lmk checks, because the IV constructor runs after crypt_set_key. Note that this is not a security bug because the memory corruption can only be triggered by root.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.12 and later | 5.10.273, 5.15.224, 6.1.191, 6.6.160, 6.12.113, 6.18.57, 7.2.11, 7.3 | Patch available | CNA |
- Linux VendorLinux Affected 4.12 and later Fixed in 5.10.273, 5.15.224, 6.1.191, 6.6.160, 6.12.113, 6.18.57, 7.2.11, 7.3 Patch available CNA
Remediation
Upgrade the Linux kernel to 5.10.273, 5.15.224, 6.1.191, 6.6.160, 6.12.113, 6.18.57, 7.2.11 or 7.3. Red Hat Enterprise Linux 6 has no fix planned, and Red Hat Enterprise Linux 8, 9 and 10 have no fix available.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Linux (Linux) Fixed in 5.10.273, 5.15.224, 6.1.191, 6.6.160, 6.12.113, 6.18.57, 7.2.11, 7.3
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-23 Threatist record created from CVE-2026-99037
- 2026-10-23 Alias added: GHSA-9xmg-p5vw-vprw
- 2026-10-29 Affected versions changed · Red Hat
- 2026-10-29 CVSS score added · Red Hat
- 2026-10-30 Fix available: Linux/Linux@412d1c1f490ed9ec5bd029883e8a626626613a70, Linux/[email protected], Linux/[email protected] +3 · CNA
- 2026-10-30 3 new references · CNA
References
Other 8
- https://git.kernel.org/stable/c/a04546fa65cbcf4a2774f93f365d747a19abb9b8
- https://git.kernel.org/stable/c/412d1c1f490ed9ec5bd029883e8a626626613a70
- https://git.kernel.org/stable/c/a50e830ded5a0d0cb9e897d1521716ba654f8c3e
- https://git.kernel.org/stable/c/9a0dab8a9d9975dec14a118b55cae2517aea5ca9
- https://git.kernel.org/stable/c/962ce265fbf5d87afeb78cf19c12e083ab0ffeb8
- https://git.kernel.org/stable/c/a1a875614dae43b43d311bb9e7a7a70eed78efe6
- https://git.kernel.org/stable/c/40ea7dfa8cd5f9aed72a55c9ca3008aee5880e6f
- https://git.kernel.org/stable/c/3195e0daf590683992edb4eed32269e569e04924
More Linux vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2021-02452 Incorrect authorization in Ubuntu linux kernel KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
Sources
- CVE-2026-99037 · CVE Program
- CVE-2026-99037 · NVD
- FIRST EPSS
- GHSA-9xmg-p5vw-vprw · GitHub Advisory Database · CC BY 4.0
- CVE-2026-99037 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences