Read the docs
TI-2026-79905 Aliases CVE-2026-55826

Customer order data exposed in GTM Server Side WordPress plugin

Priority MEDIUM 44CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-200.

Summary

The GTM Server Side plugin by stape.io is affected from version 2.0.0 before version 2.1.48. The WooCommerce purchase event tracking exposes sensitive information (CWE-200), rendering another customer's full order data, including personally identifiable information, into the page's JavaScript dataLayer. An unauthenticated remote attacker can trigger this without holding an account.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

The GTM Server Side plugin by stape.io implements server-side tracking on WordPress websites. From version 2.0.0 to before version 2.1.48, the WooCommerce purchase event tracking mechanism allows an unauthenticated attacker to trigger the rendering of another customer's full order data — including personally identifiable information (PII) — into the page's JavaScript dataLayer. This issue has been patched in version 2.1.48.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00337 27th percentileScored 2026-11-07
Fix Fixed gtm-server-side-wordpress-plugin (stape-io): 2.1.48

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
stape-iogtm-server-side-wordpress-plugin2.0.0 to before 2.1.482.1.48Patch availableCNA
  • gtm-server-side-wordpress-plugin Vendorstape-io Affected 2.0.0 to before 2.1.48 Fixed in 2.1.48 Patch available CNA

Remediation

Update the gtm-server-side-wordpress-plugin to version 2.1.48, which fixes the issue.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA gtm-server-side-wordpress-plugin (stape-io) Fixed in 2.1.48

Timeline

  1. 2026-10-23 Threatist record created from CVE-2026-55826
  2. 2026-10-24 Priority changed: MEDIUM → LOW
  3. 2026-10-29 CISA SSVC decision points changed
  4. 2026-10-29 Priority changed: LOW → MEDIUM

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences