Denial of service in Seroval fromJSON via unvalidated array length
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.
Summary
Seroval versions from 1.4.1 before 1.6.8 are affected. The fromJSON and fromCrossJSON functions do not check that an array node's element list is an actual array, so the decoder trusts an attacker-controlled length (CWE-770). An unauthenticated remote attacker can send a small crafted payload that makes the process exhaust memory or block its thread, causing denial of service. This is a residual bypass of an earlier fix.
Written with Claude Haiku 5.5 from the sources below · 2026-11-02
Description from the CNA
Seroval facilitates JavaScript value stringification, including complex structures beyond JSON.stringify capabilities. From 1.4.1 until 1.6.8, fromJSON and fromCrossJSON do not require an array node's element list to be an actual array. A small crafted payload can supply an attacker-controlled length that determines memory allocation and decoder iterations independently of payload size, allowing an unauthenticated request to exhaust the process or block its thread. This issue is a residual bypass of the remediation for CVE-2026-23957. This issue is fixed in version 1.6.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| lxsmnsyc | seroval | 1.4.1 to before 1.6.8 | 1.6.8 | Patch available | CNA |
| — | seroval (npm) | 1.4.1 to before 1.6.8 | 1.6.8 | Patch available | GHSA-wp97-x4hv-qvhp |
- seroval Vendorlxsmnsyc Affected 1.4.1 to before 1.6.8 Fixed in 1.6.8 Patch available CNA
- seroval (npm) Vendor— Affected 1.4.1 to before 1.6.8 Fixed in 1.6.8 Patch available GHSA-wp97-x4hv-qvhp
Remediation
Upgrade the seroval npm package to version 1.6.8, which fixes this issue. Red Hat lists Ansible Automation Orchestrator 2026 as affected, with no fix available.
Written with Claude Haiku 5.5 from the sources below · 2026-11-02
- Fix · CNA seroval (lxsmnsyc) Fixed in 1.6.8
- Fix · GHSA-wp97-x4hv-qvhp seroval (npm) Fixed in 1.6.8 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Ansible Automation Orchestrator 2026 | Affected | No fix yet |
Timeline
- 2026-10-26 Threatist record created from CVE-2026-116584
- 2026-10-27 Affected versions changed · Red Hat
- 2026-10-27 CVSS score added · Red Hat
- 2026-10-27 Priority changed: MEDIUM → LOW
- 2026-10-28 Alias added: GHSA-wp97-x4hv-qvhp
- 2026-10-28 Fix available: npm/[email protected] · GHSA-wp97-x4hv-qvhp
- 2026-10-28 CVSS score added · GHSA-wp97-x4hv-qvhp
- 2026-10-28 Weakness changed · GHSA-wp97-x4hv-qvhp
- 2026-10-28 5 new references · GHSA-wp97-x4hv-qvhp
- 2026-11-02 CISA SSVC decision points changed
References
More lxsmnsyc vulnerabilities
- TI-2026-42747 Seroval: `seroval.fromJSON()` Promise resolver type confusion invokes attacker-controlled methods during deserialization CVSS 3.1CRITICAL 9.8
- TI-2026-66132 Seroval: `fromJSON()` Promise thenable assimilation invokes plugin-produced callables (bypass of CVE-2026-59940) CVSS 3.1CRITICAL 9.8
- TI-2026-19109 seroval Affected by Prototype Pollution via JSON Deserialization CVSS 3.1CRITICAL 9.8
- TI-2026-19298 seroval affected by Denial of Service via RegExp serialization CVSS 3.1HIGH 7.5
- TI-2026-80917 Seroval fromJSON deserializer hangs on crafted sequence, causing DoS CVSS 3.1HIGH 7.5
- TI-2026-66131 Seroval: Memory exhaustion via unchecked TypedArray length in JSON deserialization CVSS 3.1HIGH 7.5
Sources
- CVE-2026-116584 · CVE Program
- CVE-2026-116584 · NVD
- FIRST EPSS
- GHSA-wp97-x4hv-qvhp · GitHub Advisory Database · CC BY 4.0
- CVE-2026-116584 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences