Heap-based buffer overflow in Tanium Index
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-122 and the CVSS impact.
Summary
Tanium Endpoint Configuration Toolset Solution from 1.51 before 1.51.60, from 1.59 before 1.59.50 and from 1.71 before 1.71.25 is affected, and the Tanium index-cx package is also affected. A heap-based buffer overflow (CWE-122) lets data be written past the end of a heap buffer. A local user with low privileges can fully compromise confidentiality, integrity and availability.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
Tanium addressed a heap-based buffer overflow vulnerability in Index.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Tanium | Endpoint Configuration Toolset Solution | 1.51 to before 1.51.60; 1.59 to before 1.59.50; 1.71 to before 1.71.25 | 1.51.60, 1.59.50, 1.71.25 | Patch available | CNA |
| Tanium | index-cx | 3.9.520 to before 3.9.520; 3.11.443 to before 3.11.443; 3.14.921 to before 3.14.921; 3.14.917 to before 3.14.917; 3.15.2420 to before 3.15.2420; 3.16.984 to before 3.16.984 | 3.9.520, 3.11.443, 3.14.921, 3.14.917, 3.15.2420, 3.16.984 | Patch available | CNA |
- Endpoint Configuration Toolset Solution VendorTanium Affected 1.51 to before 1.51.60; 1.59 to before 1.59.50; 1.71 to before 1.71.25 Fixed in 1.51.60, 1.59.50, 1.71.25 Patch available CNA
- index-cx VendorTanium Affected 3.9.520 to before 3.9.520; 3.11.443 to before 3.11.443; 3.14.921 to before 3.14.921; 3.14.917 to before 3.14.917; 3.15.2420 to before 3.15.2420; 3.16.984 to before 3.16.984 Fixed in 3.9.520, 3.11.443, 3.14.921, 3.14.917, 3.15.2420, 3.16.984 Patch available CNA
Remediation
Fixed versions are 1.51.60, 1.59.50 and 1.71.25 for Tanium Endpoint Configuration Toolset Solution, and 3.9.520, 3.11.443, 3.14.917, 3.14.921, 3.15.2420 and 3.16.984 for index-cx.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA Endpoint Configuration Toolset Solution (Tanium) Fixed in 1.51.60, 1.59.50, 1.71.25
- Fix · CNA index-cx (Tanium) Fixed in 3.9.520, 3.11.443, 3.14.921, 3.14.917, 3.15.2420, 3.16.984
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Tanium Endpoint Configuration Toolset Solution 1.51.60, 1.59.50, 1.71.25
10 records Highest priority Priority LOW 10 LOW
Other records, highest priority first
- TI-2026-81462 Local privilege escalation in Tanium End-User NotificationsPriority LOW 35
- TI-2026-81461 Local privilege escalation in Tanium End-User NotificationsPriority LOW 35
- TI-2026-81460 Local privilege escalation in Tanium End-User NotificationsPriority LOW 35
Timeline
- 2026-10-27 Threatist record created from CVE-2026-108307
- 2026-10-27 Alias added: GHSA-x7c3-2vm4-9496
- 2026-10-28 Priority changed: MEDIUM → LOW
- 2026-11-04 CISA SSVC decision points changed
References
Other 1
More Tanium vulnerabilities
- TI-2026-81473 Unauthorized code execution in Tanium Threat Response CVSS 3.1HIGH 8.8
- TI-2026-81459 Tanium Certificate Manager unauthorized code execution vulnerability CVSS 3.1HIGH 8.8
- TI-2026-59476 Tanium addressed a SQL injection vulnerability in Threat Response. CVSS 3.1HIGH 8.8
- TI-2026-08094 Tanium addressed an unauthorized code execution vulnerability in Connect. CVSS 3.1HIGH 8.8
- TI-2026-08093 Tanium addressed an unauthorized code execution vulnerability in Connect. CVSS 3.1HIGH 8.8
- TI-2025-13983 Tanium addressed an improper input validation vulnerability in Deploy. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-108307 · CVE Program
- CVE-2026-108307 · NVD
- FIRST EPSS
- GHSA-x7c3-2vm4-9496 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences