Read the docs

Missing authorization in PayPlug for WooCommerce lets attackers delete orders

Priority LOW 34CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.

Summary

The PayPlug for WooCommerce (Official) WordPress plugin from 2.8.0 before 3.1.1 performs no capability or ownership check on a set of unauthenticated AJAX actions that take a caller-supplied order identifier. An unauthenticated remote attacker can modify, read the contents of, and permanently delete arbitrary WooCommerce orders. The flaw is classified as CWE-862 (missing authorization). A public exploit is linked in the references.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

The PayPlug for WooCommerce (Official) WordPress plugin before 3.1.1 does not perform any capability or ownership check on a set of unauthenticated AJAX actions that operate on a caller-supplied order identifier, allowing unauthenticated attackers to modify, read the contents of, and permanently delete arbitrary WooCommerce orders.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00209 11th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed PayPlug for WooCommerce (Official) (Unknown): 3.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPayPlug for WooCommerce (Official)2.8.0 to before 3.1.13.1.1Patch availableCNA
  • PayPlug for WooCommerce (Official) VendorUnknown Affected 2.8.0 to before 3.1.1 Fixed in 3.1.1 Patch available CNA

Remediation

Update PayPlug for WooCommerce (Official) to version 3.1.1 or later, which fixes the flaw. CISA does not list this vulnerability in its Known Exploited Vulnerabilities catalog.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA PayPlug for WooCommerce (Official) (Unknown) Fixed in 3.1.1

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    PayPlug for WooCommerce (Official) 3.1.1

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2026-81694 PayPlug for WooCommerce Unauthenticated Order Key Disclosure and CancellationPriority LOW 34

Timeline

  1. 2026-10-28 Threatist record created from CVE-2026-113813
  2. 2026-10-28 Alias added: GHSA-pp3q-4jh2-gvr2
  3. 2026-10-28 CVSS score added · CISA ADP
  4. 2026-10-28 Weakness changed · CISA ADP
  5. 2026-10-28 CISA SSVC decision points changed

References

Sources