Cross-site scripting in Highcharts Grid icon definitions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Highcharts Grid passes every key of custom icon definitions to setAttribute on SVG path elements, which allows event-handler attributes. Affected are highcharts before 13.1.0 and @highcharts/grid-lite and @highcharts/grid-pro from 2.3.0 before 3.2.0. An attacker with low privileges who controls Grid configuration can replace default icons, and script runs in the page origin when a user hovers over or activates the icon. This is cross-site scripting (CWE-79).
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
Description from the CNA
Highcharts JS is a JavaScript charting library based on SVG. From 2.3.0 until 3.2.0, Highcharts Grid creates SVG path elements from rendering.icons object definitions and previously copied every child key with setAttribute. An attacker who controls Grid configuration can supply event-handler attribute names in an icon definition. Because custom icons override built-ins, the attacker can replace default sort or pagination icons, and script runs in the hosting page origin when a user hovers over or activates the affected icon. This issue is fixed in 3.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| highcharts | highcharts | before 13.1.0 | 13.1.0 | Patch available | CNA |
| highcharts | grid-lite | 2.3.0 to before 3.2.0 | 3.2.0 | Patch available | CNA |
| highcharts | grid-pro | 2.3.0 to before 3.2.0 | 3.2.0 | Patch available | CNA |
| — | @highcharts/grid-lite (npm) | 2.3.0 to before 3.2.0 | 3.2.0 | Patch available | GHSA-6g3c-p4fg-xv47 |
| — | @highcharts/grid-pro (npm) | 2.3.0 to before 3.2.0 | 3.2.0 | Patch available | GHSA-6g3c-p4fg-xv47 |
- highcharts Vendorhighcharts Affected before 13.1.0 Fixed in 13.1.0 Patch available CNA
- grid-lite Vendorhighcharts Affected 2.3.0 to before 3.2.0 Fixed in 3.2.0 Patch available CNA
- grid-pro Vendorhighcharts Affected 2.3.0 to before 3.2.0 Fixed in 3.2.0 Patch available CNA
- @highcharts/grid-lite (npm) Vendor— Affected 2.3.0 to before 3.2.0 Fixed in 3.2.0 Patch available GHSA-6g3c-p4fg-xv47
- @highcharts/grid-pro (npm) Vendor— Affected 2.3.0 to before 3.2.0 Fixed in 3.2.0 Patch available GHSA-6g3c-p4fg-xv47
Remediation
Upgrade highcharts to 13.1.0 and @highcharts/grid-lite and @highcharts/grid-pro to 3.2.0. Red Hat lists Red Hat Enterprise Linux 8, 9 and 10 and Red Hat Enterprise Linux AI (RHEL AI) 3 as affected with no fix available.
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
- Fix · CNA highcharts (highcharts) Fixed in 13.1.0
- Fix · CNA grid-lite (@highcharts) Fixed in 3.2.0
- Fix · CNA grid-pro (@highcharts) Fixed in 3.2.0
- Fix · GHSA-6g3c-p4fg-xv47 @highcharts/grid-lite (npm) Fixed in 3.2.0 Advisory →
- Fix · GHSA-6g3c-p4fg-xv47 @highcharts/grid-pro (npm) Fixed in 3.2.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-28 Threatist record created from CVE-2026-118242
- 2026-10-28 Alias added: GHSA-6g3c-p4fg-xv47
- 2026-10-28 Fix available: npm/@highcharts/[email protected], npm/@highcharts/[email protected] · GHSA-6g3c-p4fg-xv47
- 2026-10-28 CVSS score added · GHSA-6g3c-p4fg-xv47
- 2026-10-28 Weakness changed · GHSA-6g3c-p4fg-xv47
- 2026-10-28 4 new references · GHSA-6g3c-p4fg-xv47
- 2026-10-30 Priority changed: MEDIUM → LOW
- 2026-10-30 Affected versions changed · Red Hat
- 2026-10-30 CVSS score added · Red Hat
- 2026-11-03 CISA SSVC decision points changed
References
More highcharts vulnerabilities
- TI-2026-82141 Highcharts Grid parses pagination language options as HTML CVSS 4.0HIGH 8.6
- TI-2026-82140 Cross-site scripting in Highcharts Dashboards fullscreen labels CVSS 4.0HIGH 8.4
- TI-2026-82139 Cross-site scripting in Highcharts Dashboards sidebar labels CVSS 4.0HIGH 8.4
- TI-2026-82131 Cross-site scripting in Highcharts Dashboards via chartConstructor CVSS 4.0HIGH 8.6
- TI-2026-82125 Cross-site scripting in Highcharts Grid Pro cell renderer attributes CVSS 4.0HIGH 8.5
- TI-2018-14772 In js/parts/SvgRenderer.js in Highcharts JS before 6.1.0, the use of backtracking regular… CVSS 3.0HIGH 7.5
Sources
- CVE-2026-118242 · CVE Program
- CVE-2026-118242 · NVD
- FIRST EPSS
- GHSA-6g3c-p4fg-xv47 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-118242 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences