Superlinear CPU use in Crass CSS parser with non-ASCII input
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
Crass, a Ruby CSS parser, is affected before version 1.0.7. Its tracking of multi-byte character positions is inefficient, so parsing time grows superlinearly with non-ASCII input (CWE-400). A remote attacker who supplies CSS containing many non-ASCII characters can consume excessive CPU, which can cause a denial of service.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
Description from the CNA
Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, when Crass parses input containing `non-ASCII characters`, inefficiencies in tracking the positions of `multi-byte characters` result in superlinear parsing time. An attacker-controlled CSS input consisting of many `non-ASCII characters` can therefore cause excessive CPU consumption and potentially denial of service. This issue is fixed in version 1.0.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rgrove | crass | before 1.0.7 | 1.0.7 | Patch available | CNA |
| — | crass (RubyGems) | before 1.0.7 | 1.0.7 | Patch available | GHSA-8vfg-2r28-hvhj |
- crass Vendorrgrove Affected before 1.0.7 Fixed in 1.0.7 Patch available CNA
- crass (RubyGems) Vendor— Affected before 1.0.7 Fixed in 1.0.7 Patch available GHSA-8vfg-2r28-hvhj
Remediation
Upgrade the RubyGems package crass to version 1.0.7, which fixes this issue. Red Hat lists Red Hat 3scale API Management Platform 2 and Red Hat Satellite 6 as affected and has no plan available for either product.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
- Fix · CNA crass (rgrove) Fixed in 1.0.7
- Fix · GHSA-8vfg-2r28-hvhj crass (RubyGems) Fixed in 1.0.7 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-30 Threatist record created from CVE-2026-61848
- 2026-10-31 Affected versions changed · Red Hat
- 2026-10-31 CVSS score added · Red Hat
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-06 CISA SSVC decision points changed
References
More rgrove vulnerabilities
- TI-2026-83291 Large numeric exponents in Crass CSS parser exhaust CPU and memory CVSS 4.0HIGH 8.9
- TI-2020-03543 Cross-site Scripting in Sanitize CVSS 3.1HIGH 7.3
- TI-2018-02737 Cross-site scripting in Ryan Grove sanitize CVSS 3.0HIGH 7.5
- TI-2026-83327 Uncontrolled recursion in Crass CSS parser exhausts stack or memory CVSS 4.0MEDIUM 6.3
- TI-2023-18617 Sanitize vulnerable to Cross-site Scripting via insufficient neutralization of `style` element content CVSS 3.1HIGH 7.1
- TI-2026-83328 Uncontrolled recursion in Crass CSS parser enables denial of service CVSS 4.0MEDIUM 6.3
Sources
- CVE-2026-61848 · CVE Program
- CVE-2026-61848 · NVD
- FIRST EPSS
- CVE-2026-61848 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences