Essential Addons for Elementor Author+ Privilege Escalation
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.
Summary
The Essential Addons for Elementor WordPress plugin before 6.8.8 does not restrict who may set the role assigned to accounts created through its registration form (CWE-269). An authenticated user with Author-level access or higher can make new accounts, including those created by unauthenticated visitors through the public form, receive a higher role such as Editor. This is an incomplete fix of CVE-2026-5193: the role validation added in 6.6.0 can be circumvented by a lower-privileged user, so versions 6.6.0 through 6.8.7 remain affected even where CVE-2026-5193 has been patched. CVSS 3.1 scores it 4.2 (MEDIUM).
Written with Claude Haiku 5.5 from the sources below · 2026-11-01
Description from the CNA
The Essential Addons for Elementor WordPress plugin before 6.8.8 does not correctly restrict who may set the role assigned to accounts created through its registration form, allowing authenticated users with Author-level access and above to cause newly registered accounts, including those created by unauthenticated visitors through the public registration form, to be granted a higher role such as Editor. This is an incomplete fix of CVE-2026-5193: the role-validation control added in 6.6.0 can be circumvented by a lower-privileged user, so versions 6.6.0 through 6.8.7 remain affected even on sites that are patched against that advisory.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Essential Addons for Elementor | 6.6.0 to before 6.8.8 | 6.8.8 | Patch available | CNA |
- Essential Addons for Elementor VendorUnknown Affected 6.6.0 to before 6.8.8 Fixed in 6.8.8 Patch available CNA
Remediation
Update the plugin to 6.8.8, which fixes this issue. Versions 6.6.0 through 6.8.7 stay affected even on sites patched for CVE-2026-5193, so that patch alone is not enough.
Written with Claude Haiku 5.5 from the sources below · 2026-11-01
- Fix · CNA Essential Addons for Elementor (Unknown) Fixed in 6.8.8
Timeline
- 2026-10-31 Threatist record created from CVE-2026-110808
- 2026-10-31 Alias added: GHSA-g69p-96gc-gv86
- 2026-11-01 CVSS score added · CISA ADP
- 2026-11-01 Weakness changed · CISA ADP
- 2026-11-01 CISA SSVC decision points changed
References
Sources
- CVE-2026-110808 · CVE Program
- CVE-2026-110808 · NVD
- FIRST EPSS
- GHSA-g69p-96gc-gv86 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences