OS command injection in Control Web Panel via valid_token route
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
Control Web Panel (CWP) before 1.29 contains an OS command injection flaw in the loopback API /valid_token/ route. The unvalidated 'user' parameter is passed unescaped into a shell_exec() call, which lets a crafted request run shell metacharacters as commands (CWE-78). An unauthenticated attacker with network access to the loopback API can execute arbitrary commands as root. The CVSS 4.0 vector indicates a local attack vector with low privileges required.
Written with Claude Haiku 5.5 from the sources below · 2026-11-07
Description from the CNA
Control Web Panel (CWP) before webpanel_version 1.29 contains an OS command injection vulnerability in the loopback API /valid_token/ route that allows unauthenticated attackers to execute arbitrary commands as root by injecting shell metacharacters into the unvalidated 'user' parameter. Attackers can send a crafted request to the /valid_token/ route, which passes the parameter unescaped into a shell_exec() call.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Control Web Panel | Control Web Panel | before 1.29 | 1.29 | Patch available | CNA |
- Control Web Panel VendorControl Web Panel Affected before 1.29 Fixed in 1.29 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:control-webpanel:webpanel:*:*:*:*:*:*:*:* | — | — | Control Web Panel |
- cpe:2.3:a:control-webpanel:webpanel:*:*:*:*:*:*:*:* Versions — — ·Control Web Panel
Remediation
Upgrade Control Web Panel to version 1.29 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-11-07
- Fix · CNA Control Web Panel (Control Web Panel) Fixed in 1.29
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Control Web Panel 1.29
4 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-83867 OS command injection in Control Web Panel restoredatabase APIPriority MEDIUM 40
- TI-2026-83866 Missing authentication in Control Web Panel exposes root API routesPriority LOW 38
- TI-2026-83870 Blind SQL injection in Control Web Panel (CWP) via user parameterPriority LOW 29
Timeline
- 2026-11-02 Threatist record created from CVE-2026-104080
- 2026-11-02 CVSS score changed · CNA
- 2026-11-02 Alias added: GHSA-79c3-cwrw-p52v
- 2026-11-03 Title updated · CNA
- 2026-11-03 CVSS score changed · CNA
- 2026-11-03 Fix available: Control Web Panel/Control Web [email protected] · CNA
- 2026-11-04 Priority changed: MEDIUM → LOW
- 2026-11-07 CISA SSVC decision points changed
- 2026-11-07 Priority changed: LOW → HIGH
References
Patch 1
More Control Web Panel vulnerabilities
- TI-2022-22082 login/index.php in CWP (aka Control Web Panel or CentOS Web Panel) 7 before 0.9.8.1147… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-30935 OS command injection in CentOS Web Panel KEVCVSS 3.1CRITICAL 9.0
- TI-2021-20554 In CWP (aka Control Web Panel or CentOS Web Panel) before 0.9.8.1107, an unauthenticated… CVSS 3.1CRITICAL 9.8
- TI-2021-20553 In CWP (aka Control Web Panel or CentOS Web Panel) before 0.9.8.1107, attackers can make… CVSS 3.1CRITICAL 9.8
- TI-2026-41408 Control Web Panel < 0.9.8.1225 Blind SQL Injection via userRes Parameter CVSS 4.0CRITICAL 9.3
- TI-2022-08811 A path traversal vulnerability in loader.php of CWP v0.9.8.1122 allows attackers to… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-104080 · CVE Program
- CVE-2026-104080 · NVD
- FIRST EPSS
- GHSA-79c3-cwrw-p52v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences