Server-side request forgery in SUSE Rancher meta proxy
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
SUSE Rancher Manager versions from 2.11.0 before 2.11.19, from 2.12.0 before 2.12.15, from 2.13.0 before 2.13.11, from 2.14.0 before 2.14.7, and from 2.15.0 before 2.15.3 are affected, along with potentially older end of life versions. The allowlist check on the /meta/proxy endpoint is evaluated where it cannot stop a request, so rejected destinations are logged but still forwarded (CWE-918). An attacker with high privileges can make the Rancher server send requests to destinations the allowlist is meant to block.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
A security vulnerability exists in the SUSE Rancher Manager meta proxy endpoint (/meta/proxy). This endpoint is intended to forward requests only to destinations that appear on a configured allowlist. The allowlist decision was evaluated in a place where it could not stop a request from being forwarded, so a rejected destination was logged but the request was still handed to the proxy's transport. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11, 2.12.0 up to 2.12.15, 2.11.0 up to 2.11.19 and potentially older EOL versions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | Rancher | 2.15.0 to before 2.15.3; 2.14.0 to before 2.14.7; 2.13.0 to before 2.13.11; 2.12.0 to before 2.12.15; 2.11.0 to before 2.11.19 | 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19 | Patch available | CNA |
- Rancher VendorSUSE Affected 2.15.0 to before 2.15.3; 2.14.0 to before 2.14.7; 2.13.0 to before 2.13.11; 2.12.0 to before 2.12.15; 2.11.0 to before 2.11.19 Fixed in 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19 Patch available CNA
Remediation
Upgrade to Rancher 2.15.3, 2.14.7, 2.13.11, 2.12.15 or 2.11.19, which contain the fix. The sources list no fixed version for Rancher releases older than 2.11.0.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
- Fix · CNA Rancher (SUSE) Fixed in 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
SUSE Rancher 2.11.19, 2.12.15 and 3 more versions
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2026-83910 Rancher Manager meta proxy leaks credentials to cloud providersPriority MEDIUM 48
Timeline
- 2026-11-02 Threatist record created from CVE-2026-88809
- 2026-11-02 CISA SSVC decision points changed
- 2026-11-02 Priority changed: MEDIUM → LOW
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences