Read the docs

Privilege escalation in GLPI via user cloning

Priority MEDIUM 40CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.

Summary

GLPI from 10.0.0 before 10.0.28 and from 11.0.0 before 11.0.10 contains a privilege escalation flaw in account cloning. An authenticated user with the Technician profile can clone a Super-Admin account with a new login and password, because User::getCloneRelations() copies all profile and group assignments without permission checks (CWE-269). The result is an attacker-controlled Super-Admin account, and the CVSS 4.0 vector shows that the attacker needs high privileges to start the attack over the network.

Written with Claude Haiku 5.5 from the sources below · 2026-11-03

Description from the CNA

GLPI 10.0.0 before 10.0.28 and 11.0.0 before 11.0.10 contains a privilege escalation vulnerability that allows authenticated users to obtain elevated profiles by cloning accounts. A user with the Technician profile can clone a Super-Admin account with a new login and password, since User::getCloneRelations() copies every Profile_User and Group_User assignment without permission checks, yielding an attacker-controlled Super-Admin account.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00488 42nd percentileScored 2026-11-07
Fix Fixed GLPI (glpi-project): 10.0.28, 11.0.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
glpi-projectGLPI10.0.0 to before 10.0.28; 11.0.0 to before 11.0.1010.0.28, 11.0.10Patch availableCNA
  • GLPI Vendorglpi-project Affected 10.0.0 to before 10.0.28; 11.0.0 to before 11.0.10 Fixed in 10.0.28, 11.0.10 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*——glpi-project
  • cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* Versions — — ·glpi-project

Remediation

Upgrade GLPI to version 10.0.28 or 11.0.10.

Written with Claude Haiku 5.5 from the sources below · 2026-11-03

  • Fix · CNA GLPI (glpi-project) Fixed in 10.0.28, 11.0.10

Timeline

  1. 2026-11-03 Threatist record created from CVE-2026-121559
  2. 2026-11-03 CISA SSVC decision points changed
  3. 2026-11-03 Priority changed: MEDIUM → LOW
  4. 2026-11-03 Alias added: GHSA-r7x3-2pgh-h4g2
  5. 2026-11-05 Priority changed: LOW → MEDIUM

References

  • TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
  • TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
  • TI-2022-15054 The Cartography (aka positions) plugin before 6.0.1 for GLPI allows remote code execution… CVSS 3.1CRITICAL 9.8
  • TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
  • TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
See all 237 →

Sources