Path traversal in Tanium Data Service
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Tanium Data Service from 4.1 before 4.1.281 and from 4.2 before 4.2.360, and Tanium Interact from 3.5.0 before 3.5.141, contain a path traversal flaw (CWE-22). Improper limitation of file paths to a restricted directory lets a network attacker with high privileges modify files outside the intended directory. The attack requires high privileges and no user interaction.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
Tanium addressed a path traversal vulnerability in Tanium Data Service.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Fixed versions are 4.1.281 and 4.2.360 for Tanium Data Service and 3.5.141 for Tanium Interact.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA Tanium Data Service (Tanium) Fixed in 4.1.281, 4.2.360
- Fix · CNA Interact (Tanium) Fixed in 3.5.141
Timeline
- 2026-11-03 Threatist record created from CVE-2026-108327
- 2026-11-04 Alias added: GHSA-c5qj-4wg7-46v3
- 2026-11-06 CISA SSVC decision points changed
References
Other 1
More Tanium vulnerabilities
- TI-2026-81473 Unauthorized code execution in Tanium Threat Response CVSS 3.1HIGH 8.8
- TI-2026-81459 Tanium Certificate Manager unauthorized code execution vulnerability CVSS 3.1HIGH 8.8
- TI-2026-59476 Tanium addressed a SQL injection vulnerability in Threat Response. CVSS 3.1HIGH 8.8
- TI-2026-08094 Tanium addressed an unauthorized code execution vulnerability in Connect. CVSS 3.1HIGH 8.8
- TI-2026-08093 Tanium addressed an unauthorized code execution vulnerability in Connect. CVSS 3.1HIGH 8.8
- TI-2025-13983 Tanium addressed an improper input validation vulnerability in Deploy. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-108327 · CVE Program
- CVE-2026-108327 · NVD
- FIRST EPSS
- GHSA-c5qj-4wg7-46v3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences