Improper access controls in Tanium Enforce allow unauthorized changes
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
Tanium Enforce versions from 3.0.0 before 3.0.373 and from 2.10.0 before 2.10.778 contain an improper access control flaw (CWE-863, Incorrect Authorization). An authenticated remote attacker with low privileges can change data they should not be able to modify, affecting integrity.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
Tanium addressed an improper access controls vulnerability in Enforce.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Tanium Enforce to version 3.0.373 or later, or to version 2.10.778 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA Enforce (Tanium) Fixed in 3.0.373, 2.10.778
Timeline
- 2026-11-03 Threatist record created from CVE-2026-116661
- 2026-11-04 Alias added: GHSA-w76g-9h88-q3vp
- 2026-11-05 Priority changed: MEDIUM → LOW
- 2026-11-06 CISA SSVC decision points changed
References
Other 1
More Tanium vulnerabilities
- TI-2026-81473 Unauthorized code execution in Tanium Threat Response CVSS 3.1HIGH 8.8
- TI-2026-81459 Tanium Certificate Manager unauthorized code execution vulnerability CVSS 3.1HIGH 8.8
- TI-2026-59476 Tanium addressed a SQL injection vulnerability in Threat Response. CVSS 3.1HIGH 8.8
- TI-2026-08094 Tanium addressed an unauthorized code execution vulnerability in Connect. CVSS 3.1HIGH 8.8
- TI-2026-08093 Tanium addressed an unauthorized code execution vulnerability in Connect. CVSS 3.1HIGH 8.8
- TI-2025-13983 Tanium addressed an improper input validation vulnerability in Deploy. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-116661 · CVE Program
- CVE-2026-116661 · NVD
- FIRST EPSS
- GHSA-w76g-9h88-q3vp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences