Warnings leak across requests in Perl CGI::Carp module
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Partial Red Hat: 4 without a fix
No CVSS vector from any source. Fix status from CNA and Red Hat.
Summary
CGI::Carp versions before 5.00 for Perl hold warnings in a package-level buffer that is never cleared between requests. Under persistent environments such as mod_perl, FastCGI or PSGI, warnings from one request are written into a later response, so request data from one user can appear in the HTML sent to another user. The weakness is CWE-488.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
CGI::Carp versions before 5.00 for Perl leak warnings across requests in persistent environments via the warningsToBrowser buffer. Warnings are held in a package-level buffer until warningsToBrowser writes them into the page as HTML comments, and the buffer is never cleared between requests. Under mod_perl, FastCGI or PSGI, warnings from one request are written into a later one. Warnings that contain one user's request data can appear in the HTML sent to another user.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | CGI | before 5.00 | 5.00 | Patch available | CNA |
- CGI Vendor— Affected before 5.00 Fixed in 5.00 Patch available CNA
Remediation
Update CGI to version 5.00. Red Hat lists Red Hat Enterprise Linux 7, 8, 9 and 10 as affected with no fix available.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA CGI Fixed in 5.00
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-11-03 Threatist record created from CVE-2026-120634
- 2026-11-04 Affected versions changed · Red Hat
- 2026-11-04 CVSS score added · Red Hat
- 2026-11-04 Alias added: GHSA-qqq9-5j87-rw35
References
Sources
- CVE-2026-120634 · CVE Program
- CVE-2026-120634 · NVD
- FIRST EPSS
- GHSA-qqq9-5j87-rw35 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-120634 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences