Cross-site scripting in Perl CGI via raw apostrophes in URLs
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Partial Red Hat: 4 without a fix
No CVSS vector from any source. Fix status from CNA and Red Hat. Impact type from CWE-79.
Summary
CGI versions from 4.62 before 5.00 for Perl allow cross-site scripting (CWE-79). The url and self_url methods return URLs that keep an apostrophe raw from the request path or a parameter. An application that places that URL in a single-quoted HTML attribute or JavaScript string is open to cross-site scripting.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
CGI versions from 4.62 before 5.00 for Perl allow cross-site scripting via a raw apostrophe in URLs returned by url and self_url. Both pass the URL through URI's canonical method, which leaves an apostrophe in the path raw and decodes the %27 that query parameter escaping produces, so an apostrophe in the request path or a parameter appears raw in the result. An application that places the URL in a single-quoted HTML attribute or JavaScript string is open to cross-site scripting.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | CGI | 4.62 to before 5.00 | 5.00 | Patch available | CNA |
- CGI Vendor— Affected 4.62 to before 5.00 Fixed in 5.00 Patch available CNA
Remediation
Upgrade CGI for Perl to version 5.00. Red Hat lists Red Hat Enterprise Linux 7, 8, 9 and 10 as affected with no fix plan available.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA CGI Fixed in 5.00
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-11-03 Threatist record created from CVE-2026-120643
- 2026-11-04 Affected versions changed · Red Hat
- 2026-11-04 CVSS score added · Red Hat
- 2026-11-04 Alias added: GHSA-c4m8-3x4v-gcxr
References
Sources
- CVE-2026-120643 · CVE Program
- CVE-2026-120643 · NVD
- FIRST EPSS
- GHSA-c4m8-3x4v-gcxr · GitHub Advisory Database · CC BY 4.0
- CVE-2026-120643 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences