Replay of consumed bearer assertions in Armeria SAML
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
LY Corporation Armeria (armeria-saml) before 1.41.1 does not enforce one-time use for bearer assertions. This allows an attacker to replay previously consumed assertion IDs within their validity period. The CVSS 4.0 vector rates the flaw high severity, with high confidentiality and integrity impact, a network attack vector and user interaction required.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
A vulnerability has been identified in armeria-saml prior to 1.41.1, where bearer assertions are not enforced for one-time use, allowing replay of previously consumed assertion IDs within their validity period.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| LY Corporation | Armeria | — | 1.41.1 | Patch available | CNA |
- Armeria VendorLY Corporation Affected — Fixed in 1.41.1 Patch available CNA
Remediation
Upgrade Armeria to version 1.41.1, which is the fixed version for armeria-saml.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA Armeria (LY Corporation) Fixed in 1.41.1
Timeline
- 2026-11-04 Threatist record created from CVE-2026-11749
- 2026-11-04 Fix available: LY Corporation/[email protected] · CNA
- 2026-11-05 Priority changed: MEDIUM → LOW
References
More LY Corporation vulnerabilities
- TI-2026-10143 Hard-coded credentials in LY Corporation Central Dogma CVSS 4.0CRITICAL 9.4
- TI-2026-10142 A vulnerability has been identified in centraldogma-server-mirror-git versions prior to… CVSS 4.0HIGH 8.8
- TI-2026-10145 LDAP injection in LY Corporation Central Dogma CVSS 4.0MEDIUM 6.9
- TI-2026-14054 A code injection vulnerability exists in the LINE Android app prior to version 26.7.2. CVSS 4.0HIGH 8.7
- TI-2026-10146 A vulnerability has been identified in armeria-xds versions prior to 1.41.0, where xDS… CVSS 4.0CRITICAL 9.1
- TI-2026-85778 Excessive memory allocation in Armeria from malformed Thrift messages CVSS 4.0HIGH 8.7
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences