Out of bounds memory access in Apache OpenOffice WMF import
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
Apache OpenOffice versions through 4.1.16 are affected. An uncontrolled memory access in the WMF import code lets a crafted WMF file cause an invalid memory access that can crash the program or corrupt memory (CWE-787). A local attacker needs a user to open the crafted file.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
An uncontrolled memory access in the WMF import code of Apache OpenOffice versions through 4.1.16 allows a crafted WMF file to cause an invalid memory access, causing program crash or memory corruption. Users are recommended to upgrade to version 4.1.17, which fixes this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Apache OpenOffice to version 4.1.17, which fixes this issue.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Timeline
- 2026-11-04 Threatist record created from CVE-2026-90629
- 2026-11-04 Alias added: GHSA-pv52-gqgr-5x2q
- 2026-11-04 CVSS score added · CISA ADP
- 2026-11-04 CISA SSVC decision points changed
- 2026-11-05 CISA SSVC decision points changed
References
More Apache Openoffice vulnerabilities
- TI-2018-07474 An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache… CVSS 3.0HIGH 7.5
- TI-2021-12639 Buffer overflow from a crafted DBF file CVSS 3.1HIGH 7.8
- TI-2014-02850 Apache OpenOffice before 4.1.1 allows remote attackers to execute arbitrary commands and… CVSS 2.0HIGH 9.3
- TI-2009-02810 Heap-based buffer overflow in the GIFLZWDecompressor::GIFLZWDecompressor function in… CVSS 2.0HIGH 9.3
- TI-2009-02809 Integer overflow in the XPMReader::ReadXPM function in filter.vcl/ixpm/svt_xpmread.cxx in… CVSS 2.0HIGH 9.3
- TI-2009-03144 filter/ww8/ww8par2.cxx in OpenOffice.org (OOo) before 3.2 allows remote attackers to… CVSS 2.0HIGH 9.3
Sources
- CVE-2026-90629 · CVE Program
- CVE-2026-90629 · NVD
- FIRST EPSS
- GHSA-pv52-gqgr-5x2q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences