Read the docs
TI-2026-85030 Aliases CVE-2026-90631GHSA-3vpc-9qf6-qvw3

Apache OpenOffice loads external links without prompt

Priority LOW 15CWE-939Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

Apache OpenOffice through 4.1.16 is affected. A missing authorization check (CWE-939) lets a crafted document load external links without a prompt. When a user opens such a document, the contents of environment variables may be transferred to the linked location.

Written with Claude Haiku 5.5 from the sources below · 2026-11-04

Description from the CNA

Apache OpenOffice documents can contain links. A missing Authorization vulnerability in Apache OpenOffice allowed an attacker to craft a document that would cause external links to be loaded without prompt, possibly transferring the contents of environment variables in the process. This issue affects Apache OpenOffice: through 4.1.16. Users are recommended to upgrade to version 4.1.17, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00207 10th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache OpenOfficeup to 4.1.16—No fix listedCNA
  • Apache OpenOffice VendorApache Affected up to 4.1.16 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:openoffice:*:*:*:*:*:*:*:*before 4.1.17VulnerableApache
  • cpe:2.3:a:apache:openoffice:*:*:*:*:*:*:*:* Versions before 4.1.17 Vulnerable ·Apache

Remediation

Upgrade Apache OpenOffice to version 4.1.17, which fixes the issue.

Written with Claude Haiku 5.5 from the sources below · 2026-11-04

Timeline

  1. 2026-11-04 Threatist record created from CVE-2026-90631
  2. 2026-11-04 Alias added: GHSA-3vpc-9qf6-qvw3
  3. 2026-11-04 CVSS score added · CISA ADP
  4. 2026-11-04 CISA SSVC decision points changed

References

  • TI-2018-07474 An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache… CVSS 3.0HIGH 7.5
  • TI-2021-12639 Buffer overflow from a crafted DBF file CVSS 3.1HIGH 7.8
  • TI-2014-02850 Apache OpenOffice before 4.1.1 allows remote attackers to execute arbitrary commands and… CVSS 2.0HIGH 9.3
  • TI-2009-02810 Heap-based buffer overflow in the GIFLZWDecompressor::GIFLZWDecompressor function in… CVSS 2.0HIGH 9.3
  • TI-2009-02809 Integer overflow in the XPMReader::ReadXPM function in filter.vcl/ixpm/svt_xpmread.cxx in… CVSS 2.0HIGH 9.3
  • TI-2009-03144 filter/ww8/ww8par2.cxx in OpenOffice.org (OOo) before 3.2 allows remote attackers to… CVSS 2.0HIGH 9.3
See all 71 →

Sources