Server-side request forgery in easyVoice via openaiBaseUrl in TTS API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
easyVoice before 0.0.23 contains a server-side request forgery flaw, tracked as CWE-918, in which the server does not restrict the target of requests built from user input. With useLLM enabled, an unauthenticated remote attacker can supply openaiBaseUrl to make the server send POST requests to loopback and internal services through the /api/v1/tts endpoints. Reflected error messages in the x-generate-tts-warning header let the attacker probe internal hosts and ports.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
easyVoice before 0.0.23 contains a server-side request forgery vulnerability that allows unauthenticated attackers to make the server send POST requests by supplying openaiBaseUrl with useLLM enabled. Attackers can target loopback and internal services through /api/v1/tts endpoints, using reflected error messages in the x-generate-tts-warning header to probe internal hosts and ports.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade easyVoice to version 0.0.23, which fixes this flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA easyVoice (cosin2077) Fixed in 0.0.23
Timeline
- 2026-11-04 Threatist record created from CVE-2026-121936
- 2026-11-04 Alias added: GHSA-5rpq-mc2h-94cc
- 2026-11-04 CISA SSVC decision points changed
- 2026-11-04 Priority changed: MEDIUM → HIGH
References
Patch 2
Sources
- CVE-2026-121936 · CVE Program
- CVE-2026-121936 · NVD
- FIRST EPSS
- GHSA-5rpq-mc2h-94cc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences