Read the docs
TI-2026-85249 Aliases CVE-2026-47678

Time-based blind SQL injection in GLPI dropdowns

Priority LOW 37CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.

Summary

GLPI, a free asset and IT management software package, is affected from 9.4.0 before 10.0.26 and from 11.0.0 before 11.0.8. Crafted values sent to the dropdown values fetching endpoint are incorporated into a database query without proper neutralization (CWE-89). Any authenticated user can submit such values to perform SQL injection.

Written with Claude Haiku 5.5 from the sources below · 2026-11-04

Description from the CNA

GLPI is a free asset and IT management software package. From 9.4.0 until 10.0.26 and 11.0.8, any authenticated user can submit crafted values to the dropdown values fetching endpoint that are incorporated into a database query. This permits SQL injection through the dropdown endpoint. This issue is fixed in versions 11.0.8 and 10.0.26.

Why it matters now

EPSS 0.00235 14th percentileScored 2026-11-07
Fix Fixed glpi (glpi-project): 10.0.26, 11.0.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
glpi-projectglpi9.4.0 to before 10.0.26; 11.0.0 to before 11.0.810.0.26, 11.0.8Patch availableCNA
  • glpi Vendorglpi-project Affected 9.4.0 to before 10.0.26; 11.0.0 to before 11.0.8 Fixed in 10.0.26, 11.0.8 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*——glpi-project
  • cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* Versions — — ·glpi-project

Remediation

Fixed versions of GLPI are 10.0.26 and 11.0.8, so install 10.0.26 on the 10.x branch or 11.0.8 on the 11.x branch.

Written with Claude Haiku 5.5 from the sources below · 2026-11-04

  • Fix · CNA glpi (glpi-project) Fixed in 10.0.26, 11.0.8

Timeline

  1. 2026-11-04 Threatist record created from CVE-2026-47678
  2. 2026-11-06 Priority changed: MEDIUM → LOW

References

  • TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
  • TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
  • TI-2022-15054 The Cartography (aka positions) plugin before 6.0.1 for GLPI allows remote code execution… CVSS 3.1CRITICAL 9.8
  • TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
  • TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
See all 237 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences