Two-factor authentication bypass in GLPI lets attackers log in
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-288.
Summary
GLPI, a free asset and IT management software package, is affected from 11.0.0 before 11.0.8. During the login phase, an authentication bypass through an alternate path (CWE-288) lets an unauthenticated user skip one-time-password verification, which defeats two-factor authentication. An unauthenticated remote attacker can log in without the second factor.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
GLPI is a free asset and IT management software package. From 11.0.0 until 11.0.8, during the login phase, an unauthenticated user could use a crafted URL to skip one-time-password verification, defeating two-factor authentication. This issue is fixed in version 11.0.8.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| glpi-project | glpi | 11.0.0 to before 11.0.8 | 11.0.8 | Patch available | CNA |
- glpi Vendorglpi-project Affected 11.0.0 to before 11.0.8 Fixed in 11.0.8 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* | — | — | glpi-project |
- cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* Versions — — ·glpi-project
Remediation
Upgrade GLPI to version 11.0.8, which fixes this issue.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA glpi (glpi-project) Fixed in 11.0.8
Timeline
- 2026-11-04 Threatist record created from CVE-2026-52848
References
More glpi-project vulnerabilities
- TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
- TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
- TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2022-15054 The Cartography (aka positions) plugin before 6.0.1 for GLPI allows remote code execution… CVSS 3.1CRITICAL 9.8
- TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences