Missing authorization in GLPI exposes documents to users
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
GLPI, a free asset and IT management software package, is affected from 0.85 before 10.0.26 and from 11.0.0 before 11.0.8. Under certain conditions, its permission logic can grant a user access to a document without confirming that the document is linked to the targeted item, a missing authorization flaw (CWE-862). An authenticated remote attacker with low privileges can view files they should not be able to access.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
GLPI is a free asset and IT management software package. From 0.85 until 10.0.26 and from 11.0.0 until 11.0.8, under certain conditions, GLPI permission logic could grant a user access to a document without confirming that the document was linked to the targeted item. This could expose the file to a user who should not be able to view it. This issue is fixed in versions 10.0.26 and 11.0.8.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| glpi-project | glpi | 0.85 to before 10.0.26; 11.0.0 to before 11.0.8 | 10.0.26, 11.0.8 | Patch available | CNA |
- glpi Vendorglpi-project Affected 0.85 to before 10.0.26; 11.0.0 to before 11.0.8 Fixed in 10.0.26, 11.0.8 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* | — | — | glpi-project |
- cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* Versions — — ·glpi-project
Remediation
The flaw is fixed in GLPI 10.0.26 and GLPI 11.0.8.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA glpi (glpi-project) Fixed in 10.0.26, 11.0.8
Timeline
- 2026-11-04 Threatist record created from CVE-2026-57152
- 2026-11-06 Priority changed: MEDIUM → LOW
References
Other 5
- https://github.com/glpi-project/glpi/security/advisories/GHSA-7v5q-w6f3-2v8p
- https://github.com/glpi-project/glpi/commit/8a71d5800c48023cb8c6cb25c6f7fd2e1bce945c
- https://github.com/glpi-project/glpi/commit/dcabe7c78f4da0f3498ebfe77c177b1b3be6d6c6
- https://github.com/glpi-project/glpi/releases/tag/10.0.26
- https://github.com/glpi-project/glpi/releases/tag/11.0.8
More glpi-project vulnerabilities
- TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
- TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
- TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2022-15054 The Cartography (aka positions) plugin before 6.0.1 for GLPI allows remote code execution… CVSS 3.1CRITICAL 9.8
- TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences