Incorrect authorization in AgentScope Bash Tool permission check
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
AgentScope by agentscope-ai from 2.0.0 before 2.0.9 is affected. The check_permissions function of the Bash Tool makes incorrect authorization decisions (CWE-863). A remote attacker without privileges or user interaction can exploit this to affect confidentiality, integrity and availability to a limited degree. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| agentscope-ai | AgentScope | 2.0.0; 2.0.1; 2.0.2; 2.0.3; 2.0.4; 2.0.5; 2.0.6; 2.0.7; 2.0.8 | 2.0.9 | Patch available | CNA |
- AgentScope Vendoragentscope-ai Affected 2.0.0; 2.0.1; 2.0.2; 2.0.3; 2.0.4; 2.0.5; 2.0.6; 2.0.7; 2.0.8 Fixed in 2.0.9 Patch available CNA
CPE names CNA · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:agentscope-ai:agentscope:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:agentscope-ai:agentscope:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
Upgrade AgentScope to version 2.0.9, which fixes the issue. The fix is patch 6b43b13.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
- Fix · CNA AgentScope (agentscope-ai) Fixed in 2.0.9
Timeline
- 2026-11-05 Threatist record created from CVE-2026-123023
- 2026-11-05 Alias added: GHSA-fh34-mp6h-q3xc
- 2026-11-05 CISA SSVC decision points changed
- 2026-11-05 Priority changed: MEDIUM → LOW
References
Patch 3
More agentscope-ai vulnerabilities
- TI-2026-58796 AgentScope through 2.0.7.post1 Arbitrary Directory Copy via add_skill CVSS 4.0HIGH 8.7
- TI-2026-85403 AgentScope MCP Workspace API OS command injection CVSS 4.0MEDIUM 6.9
- TI-2026-85427 Missing authentication in AgentScope Agent Service user ID handling CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-123023 · CVE Program
- CVE-2026-123023 · NVD
- FIRST EPSS
- GHSA-fh34-mp6h-q3xc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences