Surfer WordPress plugin leaks API key, enabling privilege escalation
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.
Summary
The Surfer WordPress plugin before 1.8.1.759 exposes a sensitive API credential on the post editor page. Its privileged REST API relies only on that same credential for authorization, which is an improper privilege management flaw (CWE-269). A user with contributor-level access or higher can read the credential and then publish arbitrary posts and perform other privileged actions. A public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Surfer | before 1.8.1.759 | 1.8.1.759 | Patch available | CNA |
- Surfer VendorUnknown Affected before 1.8.1.759 Fixed in 1.8.1.759 Patch available CNA
Remediation
Update the Surfer WordPress plugin to version 1.8.1.759 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Surfer (Unknown) Fixed in 1.8.1.759
Timeline
- 2026-11-06 Threatist record created from CVE-2026-118639
- 2026-11-06 Alias added: GHSA-gmmp-4j2q-5jgv
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 Weakness changed · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
Sources
- CVE-2026-118639 · CVE Program
- CVE-2026-118639 · NVD
- FIRST EPSS
- GHSA-gmmp-4j2q-5jgv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences